Firefox 51.0.1 prints only blank pages

RESOLVED FIXED in Firefox 54

Status

()

Core
Printing: Output
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: S Marsh, Assigned: bobowen, NeedInfo)

Tracking

51 Branch
mozilla55
x86_64
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox54 fixed, firefox55 fixed)

Details

(Whiteboard: [dupme 2017-03-03])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

Opened FF
Navigated to any web page
CTRL-P to print
Printed 1 (or any number of pages)



Actual results:

Received only a blank page


Expected results:

Should have printed something

Tried "What did you do (above) several times on a variety of web sites.  Same result.
(Reporter)

Comment 1

a year ago
Have now had this problem on 5 different Win7 PCs.
(Reporter)

Comment 2

a year ago
Have also tried the "Refresh Firefox" option in Troubleshooting Information.
We need more information to track down the issue:
1. Please open the "Help" menu.
2. Select "Troubleshotting information".
3. Click the buttong "Copy text to clipboard".
4. Paste the information here.
Thank you.
Flags: needinfo?(smarsh)
(Reporter)

Comment 4

a year ago
Application Basics
------------------

Name: Firefox
Version: 51.0.1
Build ID: 20170125094131
Update Channel: release
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
OS: Windows_NT 6.1
Multiprocess Windows: 1/1 (Enabled by default)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Adobe Acrobat DC - Create PDF
Version: 15.01.01
Enabled: true
ID: web2pdfextension.15@web2pdf.adobedotcom

Name: Application Update Service Helper
Version: 1.0
Enabled: true
ID: aushelper@mozilla.org

Name: Diagnostics
Version: 1.0
Enabled: true
ID: diagnostics@mozilla.org

Name: Multi-process staged rollout
Version: 1.7
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0.5
Enabled: true
ID: firefox@getpocket.com

Name: Send HSTS Priming Requests
Version: 1.0
Enabled: true
ID: hsts-priming@mozilla.org

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Name: Firefox Hotfix
Version: 20160826.01
Enabled: false
ID: firefox-hotfix@mozilla.org

Name: WebEx Productivity Tools
Version: 2.0
Enabled: false
ID: ocplugin@webex.com

Graphics
--------

Features
Compositing: Direct3D 11
Asynchronous Pan/Zoom: wheel input enabled
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA Quadro K2200 Direct3D11 vs_5_0 ps_5_0)
WebGL2 Renderer: Google Inc. -- ANGLE (NVIDIA Quadro K2200 Direct3D11 vs_5_0 ps_5_0)
Hardware H264 Decoding: Yes; Using D3D9 API
Audio Backend: wasapi
Direct2D: true
DirectWrite: true (6.2.9200.21976)
GPU #1
Active: Yes
Description: NVIDIA Quadro K2200
Vendor ID: 0x10de
Device ID: 0x13ba
Driver Version: 10.18.13.6256
Driver Date: 5-10-2016
Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Subsys ID: 109710de
RAM: 4096

Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
Decision Log
D3D9_COMPOSITING:
disabled by default: Disabled by default




Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 2
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 8
browser.privatebrowsing.autostart: true
browser.sessionstore.upgradeBackup.latestBuildID: 20140923175406
browser.startup.homepage_override.buildID: 20170125094131
browser.startup.homepage_override.mstone: 51.0.1
browser.tabs.loadInBackground: false
browser.tabs.remote.autostart.2: true
browser.urlbar.autocomplete.enabled: false
browser.urlbar.suggest.bookmark: false
browser.urlbar.suggest.history: false
browser.urlbar.suggest.openpage: false
dom.apps.lastUpdate.buildID: 20161019084923
dom.apps.lastUpdate.mstone: 49.0.2
dom.apps.reset-permissions: true
dom.max_script_run_time: 0
dom.mozApps.used: true
extensions.lastAppVersion: 51.0.1
font.internaluseonly.changed: true
gfx.crash-guard.d3d11layers.appVersion: 51.0.1
gfx.crash-guard.d3d11layers.deviceID: 0x13ba
gfx.crash-guard.d3d11layers.driverVersion: 10.18.13.6256
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.glcontext.gfx.driver-init.direct3d11-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-d3d11: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-warp: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-try-d3d11: true
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.d3d9video: 2
gfx.crash-guard.status.glcontext: 2
gfx.direct3d.last_used_feature_level_idx: 0
gfx.driver-init.appVersion: 42.0
gfx.driver-init.deviceID: 0x0102
gfx.driver-init.driverVersion: 9.17.10.3347
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
media.benchmark.vp9.fps: 244
media.benchmark.vp9.versioncheck: 1
media.gmp-eme-adobe.abi: x86-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1462296361
media.gmp-eme-adobe.version: 17
media.gmp-gmpopenh264.abi: x86-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1471477192
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20170125094131
media.gmp-manager.lastCheck: 1486164757
media.gmp-widevinecdm.abi: x86-msvc-x64
media.gmp-widevinecdm.lastUpdate: 1474483369
media.gmp-widevinecdm.version: 1.4.8.903
media.gmp.storage.version.observed: 1
media.hardware-video-decoding.failed: false
media.webrtc.debug.log_file: C:\Users\smarsh\AppData\Local\Temp\WebRTC.log
media.youtube-ua.override.to: 43
network.auth.allow-subresource-auth: 2
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1485885865
places.history.expiration.transient_current_max_pages: 122334
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
print.printer_Adobe_PDF.print_bgcolor: true
print.printer_Adobe_PDF.print_bgimages: true
print.printer_Adobe_PDF.print_colorspace:
print.printer_Adobe_PDF.print_command:
print.printer_Adobe_PDF.print_downloadfonts: false
print.printer_Adobe_PDF.print_duplex: 2621501
print.printer_Adobe_PDF.print_edge_bottom: 0
print.printer_Adobe_PDF.print_edge_left: 0
print.printer_Adobe_PDF.print_edge_right: 0
print.printer_Adobe_PDF.print_edge_top: 0
print.printer_Adobe_PDF.print_evenpages: true
print.printer_Adobe_PDF.print_footercenter:
print.printer_Adobe_PDF.print_footerleft: &PT
print.printer_Adobe_PDF.print_footerright: &D
print.printer_Adobe_PDF.print_headercenter:
print.printer_Adobe_PDF.print_headerleft: &T
print.printer_Adobe_PDF.print_headerright: &U
print.printer_Adobe_PDF.print_in_color: true
print.printer_Adobe_PDF.print_margin_bottom: 0.5
print.printer_Adobe_PDF.print_margin_left: 0.5
print.printer_Adobe_PDF.print_margin_right: 0.5
print.printer_Adobe_PDF.print_margin_top: 0.5
print.printer_Adobe_PDF.print_oddpages: true
print.printer_Adobe_PDF.print_orientation: 1
print.printer_Adobe_PDF.print_page_delay: 50
print.printer_Adobe_PDF.print_paper_data: -1
print.printer_Adobe_PDF.print_paper_height: 279.00
print.printer_Adobe_PDF.print_paper_name:
print.printer_Adobe_PDF.print_paper_size_type: 0
print.printer_Adobe_PDF.print_paper_size_unit: 1
print.printer_Adobe_PDF.print_paper_width: 215.00
print.printer_Adobe_PDF.print_plex_name:
print.printer_Adobe_PDF.print_resolution: 1200
print.printer_Adobe_PDF.print_resolution_name:
print.printer_Adobe_PDF.print_reversed: false
print.printer_Adobe_PDF.print_scaling: 0.70
print.printer_Adobe_PDF.print_shrink_to_fit: true
print.printer_Adobe_PDF.print_to_file: false
print.printer_Adobe_PDF.print_unwriteable_margin_bottom: 0
print.printer_Adobe_PDF.print_unwriteable_margin_left: 0
print.printer_Adobe_PDF.print_unwriteable_margin_right: 0
print.printer_Adobe_PDF.print_unwriteable_margin_top: 0
print.printer_LLN-North.print_bgcolor: true
print.printer_LLN-North.print_bgimages: true
print.printer_LLN-North.print_colorspace:
print.printer_LLN-North.print_command:
print.printer_LLN-North.print_downloadfonts: false
print.printer_LLN-North.print_duplex: 2621501
print.printer_LLN-North.print_edge_bottom: 0
print.printer_LLN-North.print_edge_left: 0
print.printer_LLN-North.print_edge_right: 0
print.printer_LLN-North.print_edge_top: 0
print.printer_LLN-North.print_evenpages: true
print.printer_LLN-North.print_footercenter:
print.printer_LLN-North.print_footerleft: &PT
print.printer_LLN-North.print_footerright: &D
print.printer_LLN-North.print_headercenter:
print.printer_LLN-North.print_headerleft: &T
print.printer_LLN-North.print_headerright: &U
print.printer_LLN-North.print_in_color: true
print.printer_LLN-North.print_margin_bottom: 0.5
print.printer_LLN-North.print_margin_left: 0.5
print.printer_LLN-North.print_margin_right: 0.5
print.printer_LLN-North.print_margin_top: 0.5
print.printer_LLN-North.print_oddpages: true
print.printer_LLN-North.print_orientation: 0
print.printer_LLN-North.print_page_delay: 50
print.printer_LLN-North.print_paper_data: 1
print.printer_LLN-North.print_paper_height: -1.00
print.printer_LLN-North.print_paper_name:
print.printer_LLN-North.print_paper_size_type: 0
print.printer_LLN-North.print_paper_size_unit: 0
print.printer_LLN-North.print_paper_width: -1.00
print.printer_LLN-North.print_plex_name:
print.printer_LLN-North.print_resolution: 600
print.printer_LLN-North.print_resolution_name:
print.printer_LLN-North.print_reversed: false
print.printer_LLN-North.print_scaling: 0.70
print.printer_LLN-North.print_shrink_to_fit: true
print.printer_LLN-North.print_to_file: false
print.printer_LLN-North.print_unwriteable_margin_bottom: 0
print.printer_LLN-North.print_unwriteable_margin_left: 0
print.printer_LLN-North.print_unwriteable_margin_right: 0
print.printer_LLN-North.print_unwriteable_margin_top: 0
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 0
security.sandbox.content.tempDirSuffix: {3ed00e6b-1c77-4adf-9e90-f475556eb7f2}
services.sync.declinedEngines:
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1484600634

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.13.1
Version in use: 4.13.1

NSS
Expected minimum version: 3.28.1
Version in use: 3.28.1

NSSSMIME
Expected minimum version: 3.28.1
Version in use: 3.28.1

NSSSSL
Expected minimum version: 3.28.1
Version in use: 3.28.1

NSSUTIL
Expected minimum version: 3.28.1
Version in use: 3.28.1

Experimental Features
---------------------

Sandbox
-------

Content Process Sandbox Level: 1

Comment 5

a year ago
I couldn't reproduce this issue, I tested on Windows 10 x 64 and on Window 7 x 32 on Release 51.0 and Firefox Latest Nightly 54.0a1.

Do you have any add-ons installed on your profile? If yes please try in safe mode: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

If you still have the issue please create a new profile, you have the steps here: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager
Component: Untriaged → Printing: Output
OS: Unspecified → Windows 7
Product: Firefox → Core
Hardware: Unspecified → x86_64
S Marsh: Does the issue happen both with Adobe PDF as printer an the LLN North printer?
(Reporter)

Comment 7

a year ago
Hani, I have tried running FF in safe mode, did not seem to make a difference, still getting only the blank page.  I have also uninstalled and reinstalled FF 51.0.1. Yesterday I uninstalled FF, downloaded and installed FF 50.1.0 without the installation manager, but it still downloaded and installed 51.0.1 (64 bit rather than 32) version on first use.  No printing change.  I will try creating a new profile.  Thank you.

Sebastian,  I get the single blank page output to either a local, USB-attached HP printer or the LLN-North printer which is a networked Lanier printer.  I will try printing to PDF and update the notes.  Thank you as well.

Comment 8

a year ago
I think this issue is probably the same (or, at least, very similar) as mine: https://bugzilla.mozilla.org/show_bug.cgi?id=1337413 . Though I get an error message and you (presumably) don't, my printers spit out a blank page.

You might want to try running the mozregression tool that Loic recommended to me, to see what iteration the problem starts with.

To do that, follow the instructions for the command-line tool here: http://mozilla.github.io/mozregression/install.html (install Python 2.7, then type "pip install -U mozregression" in a command prompt window).

Then type "mozregression --good=50" into command prompt. It will download and open a nightly build of Firefox. You then try to recreate the issue. If something actually prints, you enter in "good"; if it's blank, enter "bad". It will then download and launch a different nightly build.

You repeat the process until it eventually determines the specific build that introduces the problem. It took about 15 minutes to go through for me.

Comment 9

a year ago
It should be fixed in FF52+.

Could you download and test Beta, please.
Link: https://www.mozilla.org/en-US/firefox/beta/all/

Updated

a year ago
Depends on: 1337413

Comment 10

a year ago
Same bug here. If I run Firefox "As administrator", it prints as expected. However if I run Firefox normally, printing results are only blank page(s). It applies to webpages as well as to PDFs.

Windows 10 64bit, Firefox 51.0.1
(Assignee)

Comment 11

a year ago
(In reply to Antanas from comment #10)
> Same bug here. If I run Firefox "As administrator", it prints as expected.
> However if I run Firefox normally, printing results are only blank page(s).
> It applies to webpages as well as to PDFs.
> 
> Windows 10 64bit, Firefox 51.0.1

Thanks for reporting, would you mind testing this on the latest beta version:
https://www.mozilla.org/en-US/firefox/beta/all/
Flags: needinfo?(antanasb)

Comment 12

a year ago
(In reply to Bob Owen (:bobowen) from comment #11)
> (In reply to Antanas from comment #10)
> > Same bug here. If I run Firefox "As administrator", it prints as expected.
> > However if I run Firefox normally, printing results are only blank page(s).
> > It applies to webpages as well as to PDFs.
> > 
> > Windows 10 64bit, Firefox 51.0.1
> 
> Thanks for reporting, would you mind testing this on the latest beta version:
> https://www.mozilla.org/en-US/firefox/beta/all/

Just installed FF 52.0b9. Now printing (to PDF and to a network printer) is OK.
Flags: needinfo?(antanasb)
(Assignee)

Comment 13

a year ago
(In reply to Antanas from comment #12)
> (In reply to Bob Owen (:bobowen) from comment #11)

> Just installed FF 52.0b9. Now printing (to PDF and to a network printer) is
> OK.

Excellent, thanks for confirming.

I think we should give the original poster a little longer to respond and then just resolve this as a duplicate.
Whiteboard: [dupme 2017-03-03]

Comment 14

a year ago
I tried the above and upgraded to the indicated FF and I still get blank pages.  This has been going on for about a month.  I've done both a windows update as well as the update to 51.01.  I also tried the reset of about:print_printer.  I cut/paste the url to chrome and it prints fine.  I've tried a couple other webpages with the same result.  I do have some windows updates that I haven't installed as I find the restarts very annoying with all the process's I tend to have open.  If I can help in any way, let me know.


The troubleshooting information is:
Application Basics
------------------

Name: Firefox
Version: 53.0b2
Build ID: 20170313154936
Update Channel: beta
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
OS: Windows_NT 6.1
Multiprocess Windows: 1/1 (Enabled by default)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: 1-Click YouTube Video Downloader
Version: 2.4.1
Enabled: true
ID: YoutubeDownloader@PeterOlayev.com

Name: Application Update Service Helper
Version: 2.0
Enabled: true
ID: aushelper@mozilla.org

Name: Diagnostics
Version: 1.0
Enabled: true
ID: diagnostics@mozilla.org

Name: Multi-process staged rollout
Version: 1.11
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0.5
Enabled: true
ID: firefox@getpocket.com

Name: Send HSTS Priming Requests
Version: 1.0
Enabled: true
ID: hsts-priming@mozilla.org

Name: Session Manager
Version: 0.8.1.13
Enabled: true
ID: {1280606b-2510-4fe0-97ef-9b5a22eafe30}

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Name: Download Accelerator Manager (DAM)
Version: 5.0.3
Enabled: false
ID: dam@tensons.com

Name: Honey
Version: 9.5.3
Enabled: false
ID: jid1-93CWPmRbVPjRQA@jetpack

Name: Video DownloadHelper
Version: 6.2.0
Enabled: false
ID: {b9db16a4-6edc-47ec-a1f4-b86292ed211d}

Graphics
--------

Features
Compositing: Direct3D 11
Asynchronous Pan/Zoom: wheel input enabled; touch input enabled
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 730 Direct3D11 vs_5_0 ps_5_0)
WebGL2 Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 730 Direct3D11 vs_5_0 ps_5_0)
Audio Backend: wasapi
Direct2D: true
DirectWrite: true (6.2.9200.21976)
GPU #1
Active: Yes
Description: NVIDIA GeForce GT 730
Vendor ID: 0x10de
Device ID: 0x1287
Driver Version: 21.21.13.7290
Driver Date: 9-16-2016
Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Subsys ID: 00000000
RAM: 2048

Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: Direct2D 1.1
AzureCanvasBackend (UI Process): skia
AzureContentBackend: Direct2D 1.1
AzureContentBackend (UI Process): skia
AzureFallbackCanvasBackend (UI Process): cairo
Decision Log
D3D9_COMPOSITING:
disabled by default: Disabled by default




Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 3
browser.download.importedFromSqlite: true
browser.download.useDownloadDir: false
browser.places.smartBookmarksVersion: 8
browser.search.suggest.enabled: false
browser.sessionstore.upgradeBackup.latestBuildID: 20170313154936
browser.startup.homepage: http://www.sgeinc.com/
browser.startup.homepage_override.buildID: 20170313154936
browser.startup.homepage_override.mstone: 53.0
browser.tabs.remote.autostart.2: true
browser.urlbar.daysBeforeHidingSuggestionsPrompt: 3
browser.urlbar.lastSuggestionsPromptDate: 20170208
dom.max_script_run_time: 0
extensions.lastAppVersion: 53.0
font.internaluseonly.changed: false
font.name.serif.x-western: Verdana
gfx.crash-guard.d3d11layers.appVersion: 52.0
gfx.crash-guard.d3d11layers.deviceID: 0x1287
gfx.crash-guard.d3d11layers.driverVersion: 21.21.13.7290
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.d3d9video: 2
media.benchmark.vp9.fps: 104
media.benchmark.vp9.versioncheck: 1
media.eme.enabled: false
media.gmp-gmpopenh264.abi: x86_64-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1486587508
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20170313154936
media.gmp-manager.lastCheck: 1489672377
media.gmp.storage.version.observed: 1
media.hardware-video-decoding.failed: false
media.webrtc.debug.log_file: C:\Users\Multics\AppData\Local\Temp\WebRTC.log
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1489081190
places.history.expiration.transient_current_max_pages: 122131
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
print.printer_ABS_PDF_Driver_v400.print_bgcolor: false
print.printer_ABS_PDF_Driver_v400.print_bgimages: false
print.printer_ABS_PDF_Driver_v400.print_duplex: -437918235
print.printer_ABS_PDF_Driver_v400.print_edge_bottom: 0
print.printer_ABS_PDF_Driver_v400.print_edge_left: 0
print.printer_ABS_PDF_Driver_v400.print_edge_right: 0
print.printer_ABS_PDF_Driver_v400.print_edge_top: 0
print.printer_ABS_PDF_Driver_v400.print_evenpages: true
print.printer_ABS_PDF_Driver_v400.print_footercenter:
print.printer_ABS_PDF_Driver_v400.print_footerleft: &PT
print.printer_ABS_PDF_Driver_v400.print_footerright: &D
print.printer_ABS_PDF_Driver_v400.print_headercenter:
print.printer_ABS_PDF_Driver_v400.print_headerleft: &T
print.printer_ABS_PDF_Driver_v400.print_headerright: &U
print.printer_ABS_PDF_Driver_v400.print_in_color: true
print.printer_ABS_PDF_Driver_v400.print_margin_bottom: 0.5
print.printer_ABS_PDF_Driver_v400.print_margin_left: 0.5
print.printer_ABS_PDF_Driver_v400.print_margin_right: 0.5
print.printer_ABS_PDF_Driver_v400.print_margin_top: 0.5
print.printer_ABS_PDF_Driver_v400.print_oddpages: true
print.printer_ABS_PDF_Driver_v400.print_orientation: 0
print.printer_ABS_PDF_Driver_v400.print_page_delay: 50
print.printer_ABS_PDF_Driver_v400.print_paper_data: 256
print.printer_ABS_PDF_Driver_v400.print_paper_height: 11.00
print.printer_ABS_PDF_Driver_v400.print_paper_name:
print.printer_ABS_PDF_Driver_v400.print_paper_size_unit: 0
print.printer_ABS_PDF_Driver_v400.print_paper_width: 8.50
print.printer_ABS_PDF_Driver_v400.print_resolution: 600
print.printer_ABS_PDF_Driver_v400.print_reversed: false
print.printer_ABS_PDF_Driver_v400.print_scaling: 1.00
print.printer_ABS_PDF_Driver_v400.print_shrink_to_fit: true
print.printer_ABS_PDF_Driver_v400.print_to_file: false
print.printer_ABS_PDF_Driver_v400.print_unwriteable_margin_bottom: 0
print.printer_ABS_PDF_Driver_v400.print_unwriteable_margin_left: 0
print.printer_ABS_PDF_Driver_v400.print_unwriteable_margin_right: 0
print.printer_ABS_PDF_Driver_v400.print_unwriteable_margin_top: 0
print.printer_Brother_MFC-9340CDW_Printer.print_bgcolor: false
print.printer_Brother_MFC-9340CDW_Printer.print_bgimages: false
print.printer_Brother_MFC-9340CDW_Printer.print_duplex: -437918235
print.printer_Brother_MFC-9340CDW_Printer.print_edge_bottom: 0
print.printer_Brother_MFC-9340CDW_Printer.print_edge_left: 0
print.printer_Brother_MFC-9340CDW_Printer.print_edge_right: 0
print.printer_Brother_MFC-9340CDW_Printer.print_edge_top: 0
print.printer_Brother_MFC-9340CDW_Printer.print_evenpages: true
print.printer_Brother_MFC-9340CDW_Printer.print_footercenter:
print.printer_Brother_MFC-9340CDW_Printer.print_footerleft: &PT
print.printer_Brother_MFC-9340CDW_Printer.print_footerright: &D
print.printer_Brother_MFC-9340CDW_Printer.print_headercenter:
print.printer_Brother_MFC-9340CDW_Printer.print_headerleft: &T
print.printer_Brother_MFC-9340CDW_Printer.print_headerright: &U
print.printer_Brother_MFC-9340CDW_Printer.print_in_color: true
print.printer_Brother_MFC-9340CDW_Printer.print_margin_bottom: 0.5
print.printer_Brother_MFC-9340CDW_Printer.print_margin_left: 0.5
print.printer_Brother_MFC-9340CDW_Printer.print_margin_right: 0.5
print.printer_Brother_MFC-9340CDW_Printer.print_margin_top: 0.5
print.printer_Brother_MFC-9340CDW_Printer.print_oddpages: true
print.printer_Brother_MFC-9340CDW_Printer.print_orientation: 0
print.printer_Brother_MFC-9340CDW_Printer.print_page_delay: 50
print.printer_Brother_MFC-9340CDW_Printer.print_paper_data: 1
print.printer_Brother_MFC-9340CDW_Printer.print_paper_height: 11.00
print.printer_Brother_MFC-9340CDW_Printer.print_paper_name:
print.printer_Brother_MFC-9340CDW_Printer.print_paper_size_unit: 0
print.printer_Brother_MFC-9340CDW_Printer.print_paper_width: 8.50
print.printer_Brother_MFC-9340CDW_Printer.print_resolution: 600
print.printer_Brother_MFC-9340CDW_Printer.print_reversed: false
print.printer_Brother_MFC-9340CDW_Printer.print_scaling: 1.00
print.printer_Brother_MFC-9340CDW_Printer.print_shrink_to_fit: true
print.printer_Brother_MFC-9340CDW_Printer.print_to_file: false
print.printer_Brother_MFC-9340CDW_Printer.print_unwriteable_margin_bottom: 0
print.printer_Brother_MFC-9340CDW_Printer.print_unwriteable_margin_left: 0
print.printer_Brother_MFC-9340CDW_Printer.print_unwriteable_margin_right: 0
print.printer_Brother_MFC-9340CDW_Printer.print_unwriteable_margin_top: 0
print.printer_PaperPort_Image_Printer.print_bgcolor: false
print.printer_PaperPort_Image_Printer.print_bgimages: false
print.printer_PaperPort_Image_Printer.print_duplex: -437918235
print.printer_PaperPort_Image_Printer.print_edge_bottom: 0
print.printer_PaperPort_Image_Printer.print_edge_left: 0
print.printer_PaperPort_Image_Printer.print_edge_right: 0
print.printer_PaperPort_Image_Printer.print_edge_top: 0
print.printer_PaperPort_Image_Printer.print_evenpages: true
print.printer_PaperPort_Image_Printer.print_footercenter:
print.printer_PaperPort_Image_Printer.print_footerleft: &PT
print.printer_PaperPort_Image_Printer.print_footerright: &D
print.printer_PaperPort_Image_Printer.print_headercenter:
print.printer_PaperPort_Image_Printer.print_headerleft: &T
print.printer_PaperPort_Image_Printer.print_headerright: &U
print.printer_PaperPort_Image_Printer.print_in_color: true
print.printer_PaperPort_Image_Printer.print_margin_bottom: 0.5
print.printer_PaperPort_Image_Printer.print_margin_left: 0.5
print.printer_PaperPort_Image_Printer.print_margin_right: 0.5
print.printer_PaperPort_Image_Printer.print_margin_top: 0.5
print.printer_PaperPort_Image_Printer.print_oddpages: true
print.printer_PaperPort_Image_Printer.print_orientation: 0
print.printer_PaperPort_Image_Printer.print_page_delay: 50
print.printer_PaperPort_Image_Printer.print_paper_data: -1
print.printer_PaperPort_Image_Printer.print_paper_height: 11.00
print.printer_PaperPort_Image_Printer.print_paper_name:
print.printer_PaperPort_Image_Printer.print_paper_size_unit: 0
print.printer_PaperPort_Image_Printer.print_paper_width: 8.50
print.printer_PaperPort_Image_Printer.print_resolution: 200
print.printer_PaperPort_Image_Printer.print_reversed: false
print.printer_PaperPort_Image_Printer.print_scaling: 1.00
print.printer_PaperPort_Image_Printer.print_shrink_to_fit: true
print.printer_PaperPort_Image_Printer.print_to_file: false
print.printer_PaperPort_Image_Printer.print_unwriteable_margin_bottom: 0
print.printer_PaperPort_Image_Printer.print_unwriteable_margin_left: 0
print.printer_PaperPort_Image_Printer.print_unwriteable_margin_right: 0
print.printer_PaperPort_Image_Printer.print_unwriteable_margin_top: 0
print.printer_ScanSoft_PDF_Create!.print_bgcolor: false
print.printer_ScanSoft_PDF_Create!.print_bgimages: false
print.printer_ScanSoft_PDF_Create!.print_duplex: -437918235
print.printer_ScanSoft_PDF_Create!.print_edge_bottom: 0
print.printer_ScanSoft_PDF_Create!.print_edge_left: 0
print.printer_ScanSoft_PDF_Create!.print_edge_right: 0
print.printer_ScanSoft_PDF_Create!.print_edge_top: 0
print.printer_ScanSoft_PDF_Create!.print_evenpages: true
print.printer_ScanSoft_PDF_Create!.print_footercenter:
print.printer_ScanSoft_PDF_Create!.print_footerleft: &PT
print.printer_ScanSoft_PDF_Create!.print_footerright: &D
print.printer_ScanSoft_PDF_Create!.print_headercenter:
print.printer_ScanSoft_PDF_Create!.print_headerleft: &T
print.printer_ScanSoft_PDF_Create!.print_headerright: &U
print.printer_ScanSoft_PDF_Create!.print_in_color: true
print.printer_ScanSoft_PDF_Create!.print_margin_bottom: 0.5
print.printer_ScanSoft_PDF_Create!.print_margin_left: 0.5
print.printer_ScanSoft_PDF_Create!.print_margin_right: 0.5
print.printer_ScanSoft_PDF_Create!.print_margin_top: 0.5
print.printer_ScanSoft_PDF_Create!.print_oddpages: true
print.printer_ScanSoft_PDF_Create!.print_orientation: 0
print.printer_ScanSoft_PDF_Create!.print_page_delay: 50
print.printer_ScanSoft_PDF_Create!.print_paper_data: 1
print.printer_ScanSoft_PDF_Create!.print_paper_height: 11.00
print.printer_ScanSoft_PDF_Create!.print_paper_name:
print.printer_ScanSoft_PDF_Create!.print_paper_size_unit: 0
print.printer_ScanSoft_PDF_Create!.print_paper_width: 8.50
print.printer_ScanSoft_PDF_Create!.print_resolution: 600
print.printer_ScanSoft_PDF_Create!.print_reversed: false
print.printer_ScanSoft_PDF_Create!.print_scaling: 1.00
print.printer_ScanSoft_PDF_Create!.print_shrink_to_fit: true
print.printer_ScanSoft_PDF_Create!.print_to_file: false
print.printer_ScanSoft_PDF_Create!.print_unwriteable_margin_bottom: 0
print.printer_ScanSoft_PDF_Create!.print_unwriteable_margin_left: 0
print.printer_ScanSoft_PDF_Create!.print_unwriteable_margin_right: 0
print.printer_ScanSoft_PDF_Create!.print_unwriteable_margin_top: 0
privacy.donottrackheader.enabled: true
security.OCSP.enabled: 0
security.sandbox.content.tempDirSuffix: {86995317-a599-4a21-bcdf-4e0e8e8770b7}
services.sync.declinedEngines:
services.sync.engine.prefs.modified: false
services.sync.lastPing: 1489640172
services.sync.lastSync: Thu Mar 16 2017 09:18:37 GMT-0400 (Eastern Standard Time)
services.sync.numClients: 1
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1489265195

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.13.1
Version in use: 4.13.1

NSS
Expected minimum version: 3.29.3
Version in use: 3.29.3

NSSSMIME
Expected minimum version: 3.29.3
Version in use: 3.29.3

NSSSSL
Expected minimum version: 3.29.3
Version in use: 3.29.3

NSSUTIL
Expected minimum version: 3.29.3
Version in use: 3.29.3

Experimental Features
---------------------

Sandbox
-------

Content Process Sandbox Level: 1
(Assignee)

Comment 15

a year ago
(In reply to guest2@sgeinc.com from comment #14)
> I tried the above and upgraded to the indicated FF and I still get blank
> pages.  This has been going on for about a month.  I've done both a windows
> update as well as the update to 51.01.  I also tried the reset of
> about:print_printer.  I cut/paste the url to chrome and it prints fine. 
> I've tried a couple other webpages with the same result.  I do have some
> windows updates that I haven't installed as I find the restarts very
> annoying with all the process's I tend to have open.  If I can help in any
> way, let me know.

Hi, are you still getting this issue on the latest Beta version?
I can't see anything in your printer prefs that look like they would cause issues.

Have you tried printing with a new profile?
You can do this by running Firefox with the following command parameters, so you can create a new one:

 firefox.exe -no-remote -P

Once you have started Firefox with the new profile, close and restart it again with the new profile and then try to print.
(Unfortunately there is a different bug where printing can fail when you first run with a new profile.)

(By the way, I'm sure you already know this but over the Windows updates, if any are recommended updates, it's probably not a great idea to run for long without updating as they often include security updates.)
Flags: needinfo?(guest2)

Comment 16

a year ago
After success of former Firefox 52 beta the bug once appeared in FF52 final again. 
Moving to a new Firefox profile solved it.

Comment 17

a year ago
The very latest update of 53.0b9 (64-bit) printed correctly on the first test page.  prior versions just printed blank pages.  I did a preview first and then print from the preview.  This used to fail.  Over the next few days I'll try some more pages to see how it goes.
Flags: needinfo?(guest2)

Comment 18

a year ago
I've run into this issue a few times in the last few months and have had some success in resolving it. Initially Refresh Settings in Firefox did temporarily fix the issue but it doesn't seem to work at all anymore. But I have found another fix which hasn't failed me yet:

In the about:config file, locate the "security.sandbox.content.level" setting 
Change value to 0
Restart Firefox, try to print again.
(Assignee)

Comment 19

a year ago
(In reply to Matt from comment #18)
> I've run into this issue a few times in the last few months and have had
> some success in resolving it. Initially Refresh Settings in Firefox did
> temporarily fix the issue but it doesn't seem to work at all anymore. But I
> have found another fix which hasn't failed me yet:
> 
> In the about:config file, locate the "security.sandbox.content.level"
> setting 
> Change value to 0
> Restart Firefox, try to print again.

Hi Matt - thanks for taking the time to add your findings here.

We really don't want you to have to turn off the sandbox to be able to print and in Firefox 55, you won't be able to use the pref any more to turn it off.

Are you testing the in latest version of Release (Firefox 53)?

If not, please upgrade and test with that.

If you are getting the issue in Firefox 53, would you mind testing by doing the following:

* in about:config set security.sandbox.windows.log to true (make sure security.sandbox.content.level is set back to 1)
* restart Firefox
* open the Browser Console (Tools->Web Developer->Browser Console) (or Cntrl+Shift+J)
* type sandbox into the "Filter output" box, you should already see some Process Sandbox BLOCKED messages
* attempt a print

If you are being blocked from using your own LocalLow directory then you should see new messages in the console like:

Process Sandbox BLOCKED: NtCreateFile for : \??\C:\Users\<username>\AppData\LocalLow\Mozilla\Temp-{b338cac5-abcc-4cfd-9d6a-331792a55b6e}\{9ae8b0fb-bdd9-49c9-bc7f-8250da061775} 

Do you see these?

(You probably want to set that logging pref back to false once you've finished.)
Flags: needinfo?(thehipi)

Comment 20

a year ago
(In reply to Bob Owen (:bobowen) from comment #19)
> (In reply to Matt from comment #18)
> > I've run into this issue a few times in the last few months and have had
> > some success in resolving it. Initially Refresh Settings in Firefox did
> > temporarily fix the issue but it doesn't seem to work at all anymore. But I
> > have found another fix which hasn't failed me yet:
> > 
> > In the about:config file, locate the "security.sandbox.content.level"
> > setting 
> > Change value to 0
> > Restart Firefox, try to print again.
> 
> Hi Matt - thanks for taking the time to add your findings here.
> 
> We really don't want you to have to turn off the sandbox to be able to print
> and in Firefox 55, you won't be able to use the pref any more to turn it off.
> 
> Are you testing the in latest version of Release (Firefox 53)?
> 
> If not, please upgrade and test with that.
> 
> If you are getting the issue in Firefox 53, would you mind testing by doing
> the following:
> 
> * in about:config set security.sandbox.windows.log to true (make sure
> security.sandbox.content.level is set back to 1)
> * restart Firefox
> * open the Browser Console (Tools->Web Developer->Browser Console) (or
> Cntrl+Shift+J)
> * type sandbox into the "Filter output" box, you should already see some
> Process Sandbox BLOCKED messages
> * attempt a print
> 
> If you are being blocked from using your own LocalLow directory then you
> should see new messages in the console like:
> 
> Process Sandbox BLOCKED: NtCreateFile for :
> \??\C:\Users\<username>\AppData\LocalLow\Mozilla\Temp-{b338cac5-abcc-4cfd-
> 9d6a-331792a55b6e}\{9ae8b0fb-bdd9-49c9-bc7f-8250da061775} 
> 
> Do you see these?
> 
> (You probably want to set that logging pref back to false once you've
> finished.)

Thank you for your reply! Unfortunately I had to quickly fix the issue remotely so didn't get a chance to check the versions of Firefox affected in this case. But it's likely I'll get this again later, I'll attempt the fix you recommended and post back when I do.
Flags: needinfo?(thehipi)

Comment 21

a year ago
My problem seems to be fixed in 53.0 (64 bit).  Hopefully it stays fixed ;)

Thanks
(Assignee)

Comment 22

a year ago
(In reply to guest2@sgeinc.com from comment #21)
> My problem seems to be fixed in 53.0 (64 bit).  Hopefully it stays fixed ;)
> 
> Thanks

Thanks for letting us know and I hope it stays fixed as well. :-)

(In reply to Matt from comment #20)

> Thank you for your reply! Unfortunately I had to quickly fix the issue
> remotely so didn't get a chance to check the versions of Firefox affected in
> this case. But it's likely I'll get this again later, I'll attempt the fix
> you recommended and post back when I do.

Thanks Matt, just to be clear, my instructions were to turn on logging to confirm what I think the issue is, not a fix.

However, I'm probably going to pre-emptively add a rule to allow read/write access via the broker to the directory we're using (even though the process should already have it). Just to try and catch any edge cases.
I'm going to have to add this rule at some point in any case, as we remove more permissions from the sandbox.

Updated

a year ago
Blocks: 1353625

Comment 23

a year ago
hi bob, we have a user in a german support forum apparently still able to reproduce the issue in firefox 53, who has provided his console output at https://www.camp-firefox.de/forum/viewtopic.php?p=1036164#p1036164
(Assignee)

Comment 24

a year ago
(In reply to [:philipp] from comment #23)
> hi bob, we have a user in a german support forum apparently still able to
> reproduce the issue in firefox 53, who has provided his console output at
> https://www.camp-firefox.de/forum/viewtopic.php?p=1036164#p1036164

Ah yes, that confirms that they at least are still getting blocked from writing to that directory, thanks.

I'll use this bug to add a rule to allow it via the broker.
I see that they are also using links here, in theory that shouldn't affect the low integrity directory, but clearly it is.
It will also affect how I add the rule.
Assignee: nobody → bobowencode
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 25

a year ago
Created attachment 8866786 [details] [diff] [review]
On Windows add a sandbox policy rule to allow read / write access to content temp dir
Attachment #8866786 - Flags: review?(jmathies)

Updated

a year ago
Attachment #8866786 - Flags: review?(jmathies) → review+
(Assignee)

Comment 26

a year ago
Created attachment 8867504 [details] [diff] [review]
On Windows add a sandbox policy rule to allow read / write access to content temp dir

xpcshell tests on try demonstrated that we shouldn't be calling the directory service off main thread:
https://hg.mozilla.org/try/rev/d1a2e36f51dc0a7b79921226c8fe95c6f1ef0427

Move code to main thread part of launch (Wr failures are unrelated):
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a9e77969ae85513df9d90b321bb01761f6d6d182

Carrying r+ from jimm, as this was just a simple move of the call.
Attachment #8866786 - Attachment is obsolete: true
(Assignee)

Updated

a year ago
Attachment #8867504 - Flags: review+

Comment 28

a year ago
Pushed by bobowencode@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ac0ebe17a85f
On Windows add a sandbox policy rule to allow read / write access to content temp dir. r=jimm
https://hg.mozilla.org/mozilla-central/rev/ac0ebe17a85f
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
(Assignee)

Comment 30

a year ago
Comment on attachment 8866786 [details] [diff] [review]
On Windows add a sandbox policy rule to allow read / write access to content temp dir

Approval Request Comment
[Feature/Bug causing the regression]:
Windows content sandbox

[User impact if declined]:
Users who don't have write access to the content process temp directory will not be able to print.

[Is this code covered by automated tests?]:
Not for printing, although this code change is in the process launching code which is run by nearly all e10s test suites.

[Has the fix been verified in Nightly?]:
Verified in local build.

[Needs manual test from QE? If yes, steps to reproduce]: 
No.

[List of other uplifts needed for the feature/fix]:
None.

[Is the change risky?]:
Low risk.

[Why is the change risky/not risky?]:
Change adds another rule to the sandbox to attempt to give access to a directory that might otherwise be blocked and cause issues.

[String changes made/needed]:
None.
Attachment #8866786 - Flags: approval-mozilla-beta?
status-firefox54: --- → affected

Updated

a year ago
Duplicate of this bug: 1358423
 approval request for a obsolete patch, could you check this bob ? Thanks !
Flags: needinfo?(bobowencode)
(Assignee)

Comment 33

a year ago
Comment on attachment 8867504 [details] [diff] [review]
On Windows add a sandbox policy rule to allow read / write access to content temp dir

Sorry wrong patch, see comment 30.
Flags: needinfo?(bobowencode)
Attachment #8867504 - Flags: approval-mozilla-beta?
(Assignee)

Updated

a year ago
Attachment #8866786 - Flags: approval-mozilla-beta?
Comment on attachment 8867504 [details] [diff] [review]
On Windows add a sandbox policy rule to allow read / write access to content temp dir

Fix a printing issue. Beta54+. Should be in 54 beta 9.
Attachment #8867504 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 35

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/66efefd445ba
status-firefox54: affected → fixed
(In reply to Bob Owen (:bobowen) from comment #30)
> [Is this code covered by automated tests?]:
> Not for printing, although this code change is in the process launching code
> which is run by nearly all e10s test suites.
> 
> [Has the fix been verified in Nightly?]:
> Verified in local build.
> 
> [Needs manual test from QE? If yes, steps to reproduce]: 
> No.

Setting qe-verify- based on Bob's assessment on manual testing needs.
Flags: qe-verify-

Comment 37

a year ago
I have had printing problems lately with Firefox on three different Windows 10 computers.
It involves online banking.Only one page is shown in preview and only one page prints with correct content.
I have no problem using other browsers.

I am using the latest version 53.03 64bit.
I have tried all solutions from above and none make any difference.
I have tried using older versions that worked before but it seems Firefox uses preferences from 53.03 and none of the old version work either.

From day one I have used Firefox and only once before did I have this issue. I have no idea how it got resolved.

I will now try beta 54 and see if that helps.

Comment 38

a year ago
I have installed beta 54 and have gotten the same results.
If I have posted here by mistake and need to start a new topic please inform me.

Comment 39

a year ago
(In reply to jmitchin from comment #38)
> I have installed beta 54 and have gotten the same results.
> If I have posted here by mistake and need to start a new topic please inform
> me.

It's probably a different issue, could you file a new bug report and paste here the bug number. In addition, it would be nice to attach a page to print, we really a testcase with such an issue.

Comment 40

11 months ago
Using ESR 52.2.0 assume it will be fixed in a later version.

Similar bug is described here attributed to "multiprocess", which fixed our issue:
https://support.mozilla.org/en-US/questions/1164329

Couldn't find a bug report attributed to "multiprocess" specifically, so posting here to seek clarification.
You need to log in before you can comment on or make changes to this bug.