Quotes in plaintext editor should be colored (to distingish from lines starting with ">")

VERIFIED FIXED in Future

Status

MailNews Core
Composition
--
enhancement
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Sascha Claus, Assigned: Jean-Francois Ducarroz)

Tracking

(Depends on: 1 bug, Blocks: 2 bugs)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P0])

(Reporter)

Description

16 years ago
Mozilla 0.9.9 {Build ID: 2002031104} on Windows 98 First Edition

1) Write an e-mail with some quoted text.
2) Insert a line beginning with ">", e.g. typing <RETURN> into a line and write
"> " before the new line.
3) It looks all the same.
3) Send the message. You see: quotes are quotes, inserted ">" are no quotes

Expected Results:
During composition, quotes should be marked to distinguish quotes and "> " at
beginning of a line.

Quotes _might_ be marked by a quote sign in inverted colors.
(Reporter)

Updated

16 years ago
Blocks: 133747

Comment 1

16 years ago
Confirming, cleaning up the summary and changing priority to "enhancement". 
Reporter, please change if you disagree w/changes.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Not able to distinguish quote ">" and " >" at beginning of a line → [RFE] Add ability to automagicly color-code quoted text in reply
(Reporter)

Comment 2

16 years ago
OK, but the patch shouldn't be a performance killer, so a full featured parsing
by  TXTtoHTMLconv wouldn't be the best :-)

Comment 3

16 years ago
I don't see OS dependency here -> Platform/OS=ALL

Reporter, do you talk about plain text editor or html editor?

The plain text editor is basically WYSIWYG, so a > at the beginning of a line
stays there and will be colored as quote.

pi
OS: Windows 98 → All
Hardware: PC → All

Comment 4

16 years ago
No, in f=f-Mode, manually entered quote-characters are space-stuffed when found
at start of line.

Comment 5

16 years ago
OK, so it looks like a bug in format flawed (as it would be better named;-).
Actually, it is bug 114954. Adding dependency.

So this bug boils down to the problem, that it is not possible to just enter
quotes (you have to use paste as quotes) manually. This is probably related to
bug 110949, where quotes are not recognized by the editor when read from the
drafts folder. 

pi
Depends on: 114954
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 6

16 years ago
Sascha Claus, please redefine the bug, incl. summary. Make sure to include what
editor this should apply to (plaintext or HTML).

Comment 7

16 years ago
I think the proposal is clear. You should clearly see what is a quote in the
editor (plain and HTML) by coloring.

pi
(Reporter)

Comment 8

16 years ago
Steps to reproduce:

1) format=flowed on.
2) Reply to a message.
3) Start a new line
4) Enter "> " and some text

Where is the difference between quoted text and the text entered by me/you?
The editor should mark the quoting. Changing the colors doesn't need much power
(play a little bit with the preferences toolbar).

Comment 9

16 years ago
Sascha, your steps and the summary don't include which editor to use. I think
you  mean the plaintext editor only, adjusting summary for you.

Boris, I think the bars in the HTML editor are already very clear. There is no
ambiguity.
Summary: [RFE] Add ability to automagicly color-code quoted text in reply → Quotes in plaintext editor should be colored (to distingish from lines starting with ">")

Comment 10

16 years ago
I don't understand. Now in plain text editor we have colored text. But if I fold
a quoted line, it stays blue, but has no quote symbol.

pi

Comment 11

16 years ago
Bug 83378 added color-coding of the quoted text.
Bug 152144 asks for the color to be user-definable instead of hard-coded.
Blocks: 152144
Depends on: 83378

Comment 12

16 years ago
We now have colored quotes. So this should be marked WFM. I don't do it because
it is pretty bad now (maybe it only reveals that the editor missbehaves).

Examples:

1) When in the middle of a quoted line you hit enter, both parts are blue. The
second part will not be mailed as a quote, though. You have to manually enter
the quote symbol >.

2) When you mark a paragraph and press delete, then immediately type something,
it is blue. Again, it is not mailed as quote.

So the coloring it completely absurd.

pi
Whiteboard: [Hixie-P0]

Comment 13

16 years ago
What is the status of this bug?

pi
(Reporter)

Comment 14

16 years ago
status is colored quotes with "completely absurd" coloring
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 15

16 years ago
Also see:
Bug 161968   Wrapping quoted lines get wrong quote status     
Bug 161969   Deleting quoted text keeps quote status

pi

Comment 16

16 years ago
This bug as originally stated is fixed and now verified.  We have color text for
quoted text and typing a ">" at the beginning of a new line within quoted plain
text the ">" is black and the quoted ">" indicators are still blue.  Using trunk
build 20021119 on winxp macosx and linux.  New bugs were logged for the
outstanding issues.
Status: RESOLVED → VERIFIED

Comment 17

15 years ago
*** Bug 143854 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.