Closed Bug 1337489 Opened 4 years ago Closed 4 years ago

HTTP 500 for all trees view due to missing comm-esr52 repo

Categories

(Tree Management Graveyard :: OrangeFactor, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emorley, Unassigned)

References

Details

Bug 1337093 added the mozilla-esr52 and comm-esr52 repos, however the all trees view (https://brasstacks.mozilla.com/orangefactor/?tree=all) now HTTP 500s.

2017/02/07 19:42:14 [error] 1597#0: *305964 FastCGI sent in stderr: "Traceback (most recent call last):
  File "/home/webtools/apps/orangefactor/lib/python2.6/site-packages/web/application.py", line 237, in process
    return self.handle()
  File "/home/webtools/apps/orangefactor/lib/python2.6/site-packages/web/application.py", line 228, in handle
    return self._delegate(fn, self.fvars, args)
  File "/home/webtools/apps/orangefactor/lib/python2.6/site-packages/web/application.py", line 409, in _delegate
    return handle_class(cls)
  File "/home/webtools/apps/orangefactor/lib/python2.6/site-packages/web/application.py", line 385, in handle_class
    return tocall(*args)
  File "/home/webtools/apps/orangefactor/src/orangefactor/server/handlers.py", line 203, in GET
    results = json.dumps(self._GET(params, body))
  File "/home/webtools/apps/orangefactor/src/orangefactor/server/handlers.py", line 295, in _GET
    pushdates = self.getPushesByDate(args)
  File "/home/webtools/apps/orangefactor/src/orangefactor/server/handlers.py", line 229, in getPushesByDate
    tree_dict = fetch_json(tree_url)
  File "/home/webtools/apps/orangefactor/src/orangefactor/server/handlers.py", line 526, in fetch_json
    response = make_request(url, headers={'Accept': 'application/json'})
  File "/home/webtools/apps/orangefactor/src/orangefactor/server/handlers.py", line 545, in make_request
    response.raise_for_status()
  File "/home/webtools/apps/orangefactor/lib/python2.6/site-packages/requests/models.py", line 862, in raise_for_status
    raise HTTPError(http_error_msg, response=self)
HTTPError: 404 Client Error: Not Found for url: https://hg.mozilla.org/releases/comm-esr52/json-pushes?tipsonly=1&startdate=2017-01-30&enddate=2017-02-06" while reading upstream, client: XXX.XXX.XXX.XXX, server: brasstacks.mozilla.com, request: "GET /orangefactor/api/bybug?startday=2017-01-30&endday=2017-02-05&bugid=1319306 HTTP/1.1", upstream: "fastcgi://127.0.0.1:9500", host: "brasstacks.mozilla.com", referrer: "https://brasstacks.mozilla.com/orang
I would revert bug 1337220 until the repos are created.
Duplicate of this bug: 1338110
(In reply to Wes Kocher (:KWierso) from comment #1)
> I would revert bug 1337220 until the repos are created.

I can't just roll back the deploy, since other changes have landed since. If comm-esr52 isn't going to be created any time soon, we should revert it's addition in the repo, then I can deploy that.

Please can you handle the removal of comm-esr52?

In the future it will be best to only request that repos be added if they already exist :-)
Flags: needinfo?(wkocher)
gps created the comm-esr52 repo, and the link in comment 0 is loading for me.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(wkocher)
Resolution: --- → FIXED
Product: Tree Management → Tree Management Graveyard
You need to log in before you can comment on or make changes to this bug.