Closed Bug 1337653 Opened 5 years ago Closed 5 years ago

HTML5 <audio>: no sound after setting currentTime

Categories

(Core :: Web Audio, defect, P2)

51 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla52
Tracking Status
firefox51 --- wontfix
firefox52 --- verified
firefox53 --- fixed

People

(Reporter: jaguilar, Assigned: padenot)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached file testuaudio.html
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

Using Web Audio Api through elementMediaSource appears to cause issue with setting audio currentTime via javascript.

- Load attached 'testaudio.html' file via Firefox 51.0
  - the script is set to automatically skip Audio to 25 seconds

- Watch console log to see that Audio progress is ongoing even without sound.



Actual results:

The audio appears to continue its progress - however no longer have audible sound.



Expected results:

Sound should have continued on.
I can confirm that this is broken on linux in 51 but works in 53 dev edition.
Status: UNCONFIRMED → NEW
Rank: 25
Ever confirmed: true
Priority: -- → P2
This is broken in 51, works in 52. If I use mozregression, the version it gives me for 51 works, which probably means we've uplifted something but not far enough.
This was broken by the uplift of bug 1317501 to beta 51 and then fixed on 52 by bug 1208316 which simplified the paths for an ending track.
Blocks: 1317501
See Also: → 1208316
Depends on: 1339438
Joseph, can you try out a current Beta build of Firefox and confirm that the issue is gone there?
Flags: needinfo?(jaguilar)
fwiw, we have a couple other reports of this on github (this broke multiple open-source libraries), and people say beta, aurora and nightly are fine. I just fixed + uplifted a test on beta, aurora (and landed it yesterday on inbound) that would have caught this (the test we had was buggy), and have a one-liner that fixes this.
Assignee: nobody → padenot
@(In reply to Ryan VanderMeulen [:RyanVM] from comment #4)
> Joseph, can you try out a current Beta build of Firefox and confirm that the
> issue is gone there?

I can confirm that this works on 52.0b6 

Thanks!
Thanks for confirming, Joseph! We're not going to land a fix for this in 51 at this point, but 52 will be shipping in early March.
Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: 1208316
Flags: needinfo?(jaguilar)
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
(In reply to Ryan VanderMeulen [:RyanVM] from comment #7)
> Thanks for confirming, Joseph! We're not going to land a fix for this in 51
> at this point, but 52 will be shipping in early March.

Cool, will inform our support team so they can handle any inquiries relating to this issue.

Thanks!
Duplicate of this bug: 1342447
Duplicate of this bug: 1344150
Updating status flags based on Comment 6. Thank you for helping us out, Joseph!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.