Closed Bug 1337875 Opened 3 years ago Closed 3 years ago

Schedule l10n repacks for fennec multi locale with specified locale revisions using an intree changesets file

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1339706

People

(Reporter: Callek, Assigned: aki)

References

Details

+++ This bug was initially created as a clone of Bug #1337825 +++

> This bug requires parsing the .json changesets file
> 
> And then passing in the explicit revisions to the mozharness commands for locales, via the task graph.

Unlike Bug 1337825, there is no (current) way to pass the locales + revisions via command line for the fennec multi-locale script, on the oustide (multi-locale script is invoked via the existing invoke of the overall build script).

While that's ugly and painful, I don't forsee us unwrapping that to something saner before we actually do need this.

Currently the android configs for release specify a file as pulled from buildbot-configs for the locales file.  After Bug 1337645 we'll have that file available in tree, so we might as well just point at it.

https://dxr.mozilla.org/mozilla-central/search?q=l10n-changesets_mobile+path%3Amulti&redirect=true

This will solve the underlying issue of needing to use a specific changeset for l10n in the multi-locale case, and avoid the need for major redesign in the short term.
Assignee: nobody → aki
I already started work in bug 1339706.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1339706
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.