Closed Bug 1338599 Opened 3 years ago Closed 3 years ago

Custom devices should default to enabled

Categories

(DevTools :: Responsive Design Mode, defect, P2)

defect

Tracking

(firefox54 fixed)

VERIFIED FIXED
Firefox 54
Tracking Status
firefox54 --- fixed

People

(Reporter: jryans, Assigned: jryans)

References

Details

(Whiteboard: [rdm-v2])

Attachments

(1 file)

When adding a custom device, you have also check the enabled checkbox for it to appear in the device selector.  It seems safe to assume most people would want them to appear by default.
Depends on: 1321675
Duplicate of this bug: 1342533
How can I try to repro this if it isn't yet possible to add custom devices to RDM-V2?
(In reply to BoffinbraiN from comment #2)
> How can I try to repro this if it isn't yet possible to add custom devices
> to RDM-V2?

I am not sure what you mean; it is possible in Nightly 54 (bug 1321675).
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Comment on attachment 8842648 [details]
Bug 1338599 - Default custom devices to enabled in RDM.

https://reviewboard.mozilla.org/r/116412/#review118092
Attachment #8842648 - Flags: review?(gl) → review+
Pushed by jryans@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/306620f9e767
Default custom devices to enabled in RDM. r=gl
https://hg.mozilla.org/mozilla-central/rev/306620f9e767
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
I have reproduced this bug with Nightly 54.0a1 (2017-02-10) (64-bit) on Ubuntu 16.04 LTS 64 Bit!

The fix's fix is verified with latest Beta!

Build ID 	: 20170529095024
User Agent 	: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
QA Whiteboard: [bugday-20170531]
I have reproduced this bug with Nightly 54.0a1 (2017-02-10) (64-bit) on Windows 10 64 Bit!

This bug's fix is verified with latest Beta!

Build ID 	:20170529025116
User Agent 	:Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
[bugday-20170531]
As per Comment 9 & Comment 10, I am marking this bug as verified fixed
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.