Location bar's auto-complete is not aligned

RESOLVED DUPLICATE of bug 1280700

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 1280700
10 months ago
10 months ago

People

(Reporter: matsaman, Unassigned)

Tracking

({dupeme, ux-efficiency})

48 Branch
dupeme, ux-efficiency
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

Newer versions of Firefox (51, at least) have location bar elements jumbled around seemingly at random compared to previous versions.

Even though the internet has never had a majority of websites with decently chosen titles, the newer location bar puts these usually useless titles first, before the URI, forcing one's eyes to track over each and every one of varying length before finding the actually half useful string: the URI.

In previous versions the title and address would both be presented left-aligned, allowing each to be read from the very left. This was fine.

Also acceptable would be URI first, then almost certainly useless HTML title after.
Even better would be if they were somehow aligned so every single second string wasn't at a different position [so each can be read from the same left alignment, as in a table].
But even better than all that would be the way it used to be, one on top of the other.

I suggest at the /very least/ a preference is added to swap the placement of the two, as it is simply a mess as is. People having to track their eyes along a meandering vertical line far from the left side of anything is not helping anyone.
Component: Untriaged → Location Bar

Updated

10 months ago
Blocks: 1181078
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dupeme, ux-efficiency
Summary: Location bar string placements unintuitive / reversed → Location bar's auto-complete is not aligned
Version: 51 Branch → 48 Branch
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1280700
You need to log in before you can comment on or make changes to this bug.