Closed Bug 1280700 Opened 5 years ago Closed 2 years ago

Investigate offering an option to display URL before page title

Categories

(Firefox :: Address Bar, enhancement, P3)

48 Branch
enhancement

Tracking

()

RESOLVED WONTFIX

People

(Reporter: rick3162, Unassigned)

References

Details

(Whiteboard: [fxsearch])

After bug 1181078 was fixed, i.e. the new design of bug 959564 was implemented (http://people.mozilla.org/~shorlander/mockups/AwesomeResults/AwesomeResults-02.html)
the search suggestions in awesomebar appear having the page title first and then the URL.


I'd suggest to offer the user a choice between having:
1. the page title first and then the URL (i.e. as it is), or
2. the URL first and then the page title.


In my opinion, while navigating to the internet, 
more valuable information is the URL than the page title.
Knowing the page title (or bookmark title) is comfortable,
but it's more important (for keeping your browsing safe) to easily check visually the target URL .

IMHO, the user should be offered an option to choose which of the title and URL to show first in the awesomebar search suggestions.


PS. Chrome's omnibox shows the URL first and then the page title.
I dont't say of course that this is better than Firefox's choice of implementation,
but either way, especially for a user switching from Chrome to Firefox,
I believe it would make it better having a choice.
I think this is worth a discussion, we briefly thought about it a couple days ago, and we want to provide a way to customize the results, but we don't know how we want to do that yet.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Summary: (new awesomebar design) Offer an option to display URL before page title in search suggestions → Investigate offering an option to display URL before page titlew
Blocks: 1262507
Whiteboard: fxsearch
Summary: Investigate offering an option to display URL before page titlew → Investigate offering an option to display URL before page title
Also offer a way to disable this as well.. many users want none of this awesomness and just want a simple text list of URLs / history.

Thanks.
I'd prefer an option to place the URL under the title like it was before. Should I open a separate bug? Or perhaps this bug should be renamed "Investigate offering an option to change URL placement in results list"
With the new bar, URLs are located far to the right and not lined up so it's impossible to scan through them. It's difficult to find which item you want. 
An option to put it back on 2 rows, where every titles and also every URLs were aligned, would be a good way to either still use the new bar or be able to realign everything.
Implemented this for myself as a Stylish stylesheet: https://github.com/nathancahill/prioritize-url

It's impossible to scan the URL results otherwise. There should definitely be an option to swap the two, or stack them like before. I've never submitted a patch for Firefox before, but I'd be happy to work on this.
The biggest issue with the new layout is that the URLs are not aligned à la Safari. While I also preferred the old look, I've found that the side-by-side arrangement becomes quite tolerable once the first column (the page title) is given a fixed width.
See Also: → 1293723
Please stop the "me too" comments, this is a bug tracker used for everyday work, and you are spamming all the users in the cc list.
The problem is pretty much clear already, so that's not going to add any technical value. You can vote for the bug yet, if you wish.
(In reply to blauggaumme from comment #3)
> I'd prefer an option to place the URL under the title like it was before.
> Should I open a separate bug?

It looks like bug 1262843 is discussing this possibility.  I support it, FWIW.
Whiteboard: fxsearch → [fxsearch]
See Also: → 1262843, 1292058
Duplicate of this bug: 1339470
Nothing done for one year, and Firefox 57 has broken all workarounds for this unwanted behavior.
That's enough of that.

Bugzilla is our issue tracker and professional working environment, not a place to air your grievances about designs or priorities. I'm restricting this bug users with editbugs privs only. 

If you have something to add that will materially  move this bug forward, please feel free to contact me with it and I will add it to the bug. In the meantime, I encourage you to move review the Bugzilla etiquette and contributor guidelines, and take them to heart.
Restrict Comments: true

We don't plan to implement this, we still think the title is more understandable and easy to remember for the user.
BUT, now that the urlbar is mostly html, it should be possible to do this with a simple userChrome css rule, changing the order of elements.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1619063
You need to log in before you can comment on or make changes to this bug.