Stub installer checkboxes spacing inconsistent

RESOLVED INVALID

Status

()

Firefox
Installer
P3
normal
RESOLVED INVALID
10 months ago
4 months ago

People

(Reporter: cbadau, Unassigned)

Tracking

53 Branch
x86_64
Windows
Points:
---

Firefox Tracking Flags

(firefox53 affected, firefox54 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
Created attachment 8838021 [details]
issue.png

[Affected versions]:
- latest Aurora 53.0a2 (2016-02-15)


[Affected platforms]:
- Windows 7
- Windows 10
- Windows 8.1

[Steps to reproduce]:
1. Launch the Firefox Stub Installer.
2. Click on the "Options" button.
3. Observe the checkboxes displayed here. 

[Expected result]:
- The spacing between checkboxes is the same, is consistent. 

[Actual result]:
- The spacing between the first and the second checkbox is bigger than the spacing between the second and the third checkbox. Please see attachment "issue.png".  

[Regression range]:
- TBD. The issue is not reproducible on latest Nightly 54.0a1 (2016-02-15).

Comment 1

10 months ago
This is from the bug 1337422 patch. It adds a second line worth of space when the checkbox label is long enough to need it, but there's some margin of error in that calculation caused by being unable to tell what the size of the checkbox itself is going to be (it varies with the display scaling setting). This issue was known to the patch's reviewer and to me (its author), but we thought it was acceptable given that the margin was pretty small. We didn't know that one of the English Aurora labels would fall right into it.
This certainly isn't worth backing out bug 1337422 over; before that the text was just unreadable in some languages, so a little extra padding in English is worth that. But I'm leaving this bug open in hopes of finding a good solution for this unintended consequence.
Priority: -- → P3
I think this is caused by the patch for bug 1334786, the patch for bug 1337422 hasn't landed in Aurora and should mitigate the over-padding somewhat. That would explain why it isn't seen in Nightly, where both patches are present.

Comment 3

10 months ago
You're right, bug 1334786 actually created this problem, and bug 1337422 does address it. I'll request uplift on bug 1337422.

Updated

10 months ago
See Also: → bug 1337422
This has been resolved by removing the entire options screen.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.