stylo: dynamic changes to text-indent on an ancestor of an anonymous table-cell don't work properly

RESOLVED FIXED

Status

()

Core
CSS Parsing and Computation
P1
normal
RESOLVED FIXED
6 months ago
5 days ago

People

(Reporter: bz, Assigned: bz)

Tracking

(Blocks: 2 bugs)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54 affected)

Details

Attachments

(1 attachment)

Created attachment 8838382 [details]
Testcase

See attached testcase.

The problem is that we're not properly restyling the ::-moz-table-cell pseudo so it's not picking up the new inherited value of text-indent.  We're probably also not restyling the ::-moz-cell-content in there, which probably needs to be done too to fix this.
(Assignee)

Updated

6 months ago
Blocks: 1288278, 1292609
Assignee: nobody → bzbarsky
Priority: -- → P1
Blocks: 1243581
Blocks: 1385831
Priority: P1 → --
Priority: -- → P1
Blocks: 1387189
Fixed by bug 1388625.
Status: NEW → RESOLVED
Last Resolved: 5 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.