Closed Bug 1340443 Opened 3 years ago Closed 3 years ago

“nativeMessaging” prevents the installation of a WebExtension

Categories

(Toolkit :: Add-ons Manager, defect, P1)

54 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla54
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- unaffected
firefox54 --- verified

People

(Reporter: cbadescu, Assigned: aswan)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Affected versions]:
- Firefox 54.0a1 (2017-02-16) 

[Affected platforms]:
- Windows 7 64-bit
- Ubuntu 16.04 32-bit

[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Create extensions.webextPermissionPrompts and set it to true.
3.Create xpinstall.signatures.dev-root and set it to true.
4.Restart the browser
5.Install the following webextension: https://addons-dev.allizom.org/en-US/firefox/addon/permissionsall02-16-17-1-2/ 

[Expected results]:
- The WebExtension is installed.

[Actual results]:
- The WebExtension is not installed and an error is displayed in the browser console.

[Regression range]
Last good build: f505911eb333d5ae8c2bf5c44f7b85add6450b53
First bad build: 70debab476881121ddfe92fc60c80cfae0a63bc7
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f505911eb333d5ae8c2bf5c44f7b85add6450b53&tochange=70debab476881121ddfe92fc60c80cfae0a63bc7 

[Additional notes]:
- This issue reproduces constantly.
- Here is a video of this issue https://www.screencast.com/t/TaG9JIkSQ  and a screenshot https://www.screencast.com/t/fB6AfGIw
Andy, do you know what could be up here? Bug 1333713 and bug 1336085 seem like potential candidates in the regression range from comment 0.
Flags: needinfo?(amckay)
[Tracking Requested - why for this release]: WebExtensions regressions are not good.
Yes, this is all part of the WebExtensions Permissions feature that aswan is looking and will be taking care of it when he's back from PTO, tomorrow. This feature is behind a flag, so no cause for concern.
Flags: needinfo?(amckay)
Assignee: nobody → aswan
Priority: -- → P1
Attachment #8840484 - Attachment is obsolete: true
Attachment #8840484 - Flags: review?(florian)
Note, this is kind of a pain to review since we have signed xpis checked into the tree, but the change here is to add the nativeMessaging permission to the test extension.  I haven't re-signed the new version yet but will before landing assuming this looks okay.
Comment on attachment 8840484 [details]
Bug 1340443 Fix reading from brand bundle and add a test

https://reviewboard.mozilla.org/r/114966/#review116452

If only my test from bug 1316187 had few enough false positives for referenced non-existing chrome files, we could have caught this on try...
Attachment #8840484 - Flags: review?(florian) → review+
Blocks: 1342142
(In reply to Andrew Swan [:aswan] from comment #6)
> Note, this is kind of a pain to review

I haven't actually reviewed the content of the XPI file, I assumed you just added the nativeMessaging permission to that add-on's manifest.
(In reply to Florian Quèze [:florian] [:flo] (PTO until February 27) from comment #8)
> I haven't actually reviewed the content of the XPI file, I assumed you just
> added the nativeMessaging permission to that add-on's manifest.

Correct.
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/45eac3e757c7
Fix reading from brand bundle and add a test r=florian
https://hg.mozilla.org/mozilla-central/rev/45eac3e757c7
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
This issue is verified as fixed on Firefox 54.0a1 (2017-02-26) under Wind 7 64-bit and Ubuntu 16.04 32-bit.

Video for this issue: https://www.screencast.com/t/rbiVEGde
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.