Closed Bug 1340885 Opened 3 years ago Closed 3 years ago

crash in print preview [@ GetCorrectedParent ][@ nsFrame::DoGetParentStyleContext const ]

Categories

(Core :: Print Preview, defect, major)

defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla54
Tracking Status
firefox52 --- unaffected
firefox53 --- unaffected
firefox54 --- verified

People

(Reporter: will69, Assigned: heycam)

References

Details

(Keywords: regression, testcase-wanted)

Crash Data

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170219110236

Steps to reproduce:

Print Preview & Print makes tab crash (with e10s) or browser crash (without).

KDE 4.11.5 running on Linux 3.12.67 (openSUSE 13.1)

libgtk-2 is 2.24.23
libgtk-3 is 3.10.9

Last good revision: 6cefe01ca7744d6ac3960c69eac833e2e65f7f8f
First bad revision: 975ce5d8f7d818cc3cd32b134e4010577d3208cd
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6cefe01ca7744d6ac3960c69eac833e2e65f7f8f&tochange=975ce5d8f7d818cc3cd32b134e4010577d3208cd
Has Regression Range: --- → yes
Has STR: --- → yes
OS: Unspecified → Linux
Hardware: Unspecified → x86
Is that a regression from bug 1331322? I can reproduce the issue on Windows 8.1.

Steps to reproduce in Nightly:
1. Open https://wiki.mozilla.org/Main_Page
2. Open print preview.

Result:
- content crash of tab
- printing is eitherbroken after that, browser console:
TypeError: ppBrowser is null[Learn More] printUtils.js:508:9
	enterPrintPreview chrome://global/content/printUtils.js:508:9
	printPreview chrome://global/content/printUtils.js:258:7
	oncommand chrome://browser/content/browser.xul:1:1
- or preview doesn't contain any content except meta data (header & footer)

Crash report: https://crash-stats.mozilla.com/report/index/e44a2107-e3e0-4e18-b5b1-3cc612170219
Blocks: 1331322
Severity: normal → major
Status: UNCONFIRMED → NEW
Crash Signature: [@ GetCorrectedParent ]
Component: Untriaged → Print Preview
Ever confirmed: true
Flags: needinfo?(cam)
Keywords: regression
OS: Linux → All
Product: Firefox → Core
Hardware: x86 → All
Summary: Regression: Crash in Print Preview → crash in print preview [@ GetCorrectedParent ]
Version: 54 Branch → Trunk
Actually, on Linux the crash signature is "nsFrame::DoGetParentStyleContext const", FWIW.

Crash reports: https://crash-stats.mozilla.com/signature/?signature=nsFrame%3A%3ADoGetParentStyleContext%20const
Crash Signature: [@ GetCorrectedParent ] → [@ GetCorrectedParent ] [@ nsFrame::DoGetParentStyleContext const ]
Summary: crash in print preview [@ GetCorrectedParent ] → crash in print preview [@ GetCorrectedParent ][@ nsFrame::DoGetParentStyleContext const ]
Duplicate of this bug: 1340833
Assignee: nobody → cam
Status: NEW → ASSIGNED
Flags: needinfo?(cam)
We have to null check because there are some frames (like nsPageFrame) that have a null mContent pointer.
Comment on attachment 8839012 [details]
Bug 1340885 - Null check frame's content when searching for NAC ancestors in GetCorrectedParent.

https://reviewboard.mozilla.org/r/113770/#review115320
Attachment #8839012 - Flags: review?(xidorn+moz) → review+
Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/73ce27f80d1a
Null check frame's content when searching for NAC ancestors in GetCorrectedParent. r=xidorn
A crashtest for this would be great.

Also, please file a follow-up bug that printing is permanently broken after
the content process crashed (if I understand comment 1 correctly).
Flags: in-testsuite?
Keywords: testcase-wanted
https://hg.mozilla.org/mozilla-central/rev/73ce27f80d1a
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Flags: qe-verify+
I have reproduced the issue in Nightly 54.0a1 (id: 20170219030209) and can confirm it is fixed in the Beta 54.0b3 build.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.