Closed Bug 1340903 Opened 4 years ago Closed 3 years ago

Crash in IPCError-browser | PDocAccessibleParent::AddChildDoc binding to proxy that can't be a outerDoc!

Categories

(Core :: Disability Access APIs, defect)

x86
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Tracking Status
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 + fixed

People

(Reporter: marcia, Assigned: tbsaunde)

Details

(Keywords: crash, regression, Whiteboard: aes+)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-fa60fec6-a50c-4b63-a5f9-72ebd2170219.
=============================================================

Seen while reviewing nightly crash data - crashes started with 20170218030212 build: http://bit.ly/2lY1vlV. All the crashes seem to be on Windows 10.

Possible regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6cefe01ca7744d6ac3960c69eac833e2e65f7f8f&tochange=d11c29c1db3a1bc96ad5792ebf8a89b2fbadcf85

Cannot tell who to ni since all the stacks in the reports seem to be a bit different.
[Tracking Requested - why for this release]: crash regression

Looks a11y related.  Bug 1338755 maybe?
Component: Layout: Block and Inline → Disability Access APIs
Flags: needinfo?(tbsaunde+mozbugs)
Keywords: regression
Tracking 54+ for this crash regression.
Attachment #8839633 - Flags: review?(eitan) → review+
Pushed by tsaunders@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c1544abd34c2
work around binding child docs to non outer DocAccessibles r=eeejay
Backed out for frequent failure of docshell/test/unit/test_setUsePrivateBrowsing.js on Linux opt and pgo:

https://hg.mozilla.org/integration/mozilla-inbound/rev/8a1a04cf1bc7c25a72694640fa772913e10459a4

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=18bc0b31d8c810180d445200a65c2ce18ad8c348&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable
Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=79235046&repo=mozilla-inbound

[task 2017-02-22T04:30:34.491150Z] 04:30:34     INFO -  TEST-START | docshell/test/unit/test_setUsePrivateBrowsing.js
[task 2017-02-22T04:30:35.649939Z] 04:30:35  WARNING -  TEST-UNEXPECTED-FAIL | docshell/test/unit/test_setUsePrivateBrowsing.js | xpcshell return code: 0
[task 2017-02-22T04:30:35.650370Z] 04:30:35     INFO -  TEST-INFO took 1159ms
[task 2017-02-22T04:30:35.654886Z] 04:30:35     INFO -  >>>>>>>
[task 2017-02-22T04:30:35.656802Z] 04:30:35     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2017-02-22T04:30:35.658670Z] 04:30:35     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2017-02-22T04:30:35.664640Z] 04:30:35     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2017-02-22T04:30:35.666969Z] 04:30:35     INFO -  running event loop
[task 2017-02-22T04:30:35.668870Z] 04:30:35     INFO -  docshell/test/unit/test_setUsePrivateBrowsing.js | Starting
[task 2017-02-22T04:30:35.670526Z] 04:30:35     INFO -  (xpcshell/head.js) | test pending (2)
[task 2017-02-22T04:30:35.672365Z] 04:30:35     INFO -  TEST-PASS | docshell/test/unit/test_setUsePrivateBrowsing.js |  - Should start out in non-private mode - false == false
[task 2017-02-22T04:30:35.674214Z] 04:30:35     INFO -  TEST-PASS | docshell/test/unit/test_setUsePrivateBrowsing.js |  - Should be able to change to private mode prior to a document load - true == true
[task 2017-02-22T04:30:35.676647Z] 04:30:35     INFO -  TEST-PASS | docshell/test/unit/test_setUsePrivateBrowsing.js |  - Should be able to change to non-private mode prior to a document load - false == false
[task 2017-02-22T04:30:35.679291Z] 04:30:35     INFO -  TEST-PASS | docshell/test/unit/test_setUsePrivateBrowsing.js |  - Should be able to change origin attributes prior to a document load - true == true
[task 2017-02-22T04:30:35.681866Z] 04:30:35     INFO -  TEST-PASS | docshell/test/unit/test_setUsePrivateBrowsing.js |  - Should be able to change origin attributes prior to a document load - false == false
[task 2017-02-22T04:30:35.686938Z] 04:30:35     INFO -  (xpcshell/head.js) | test function () {
[task 2017-02-22T04:30:35.688934Z] 04:30:35     INFO -      [native code]
[task 2017-02-22T04:30:35.690672Z] 04:30:35     INFO -  } pending (3)
[task 2017-02-22T04:30:35.692334Z] 04:30:35     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (3)
[task 2017-02-22T04:30:35.694182Z] 04:30:35     INFO -  "CONSOLE_MESSAGE: (info) No chrome package registered for chrome://branding/locale/brand.properties"
[task 2017-02-22T04:30:35.695997Z] 04:30:35     INFO -  "CONSOLE_MESSAGE: (info) No chrome package registered for chrome://branding/locale/brand.properties"
[task 2017-02-22T04:30:35.698128Z] 04:30:35     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "Only internal code is allowed to set the usePrivateBrowsing attribute" {file: "/home/worker/workspace/build/tests/xpcshell/tests/docshell/test/unit/test_setUsePrivateBrowsing.js" line: 18}]"
[task 2017-02-22T04:30:35.702998Z] 04:30:35     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "Only internal code is allowed to set the usePrivateBrowsing attribute" {file: "/home/worker/workspace/build/tests/xpcshell/tests/docshell/test/unit/test_setUsePrivateBrowsing.js" line: 22}]"
[task 2017-02-22T04:30:35.705007Z] 04:30:35     INFO -  (xpcshell/head.js) | test function () {
[task 2017-02-22T04:30:35.706683Z] 04:30:35     INFO -      [native code]
[task 2017-02-22T04:30:35.708302Z] 04:30:35     INFO -  } finished (2)
[task 2017-02-22T04:30:35.710192Z] 04:30:35  WARNING -  TEST-UNEXPECTED-FAIL | docshell/test/unit/test_setUsePrivateBrowsing.js |  - Missing expected exception. Should not be able to change private browsing state after initial load has started
[task 2017-02-22T04:30:35.712192Z] 04:30:35     INFO -      /home/worker/workspace/build/tests/xpcshell/tests/docshell/test/unit/test_setUsePrivateBrowsing.js:null:48
[task 2017-02-22T04:30:35.714135Z] 04:30:35     INFO -      _run_next_test@/home/worker/workspace/build/tests/xpcshell/head.js:1554:9
[task 2017-02-22T04:30:35.716112Z] 04:30:35     INFO -      run@/home/worker/workspace/build/tests/xpcshell/head.js:703:9
[task 2017-02-22T04:30:35.718739Z] 04:30:35     INFO -      _do_main@/home/worker/workspace/build/tests/xpcshell/head.js:211:5
[task 2017-02-22T04:30:35.720817Z] 04:30:35     INFO -      _execute_test@/home/worker/workspace/build/tests/xpcshell/head.js:546:5
[task 2017-02-22T04:30:35.726588Z] 04:30:35     INFO -      @-e:1:1
(In reply to Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) from comment #5)
> Backed out for frequent failure of
> docshell/test/unit/test_setUsePrivateBrowsing.js on Linux opt and pgo:

are you sure it was this patch?  that seems pretty unlikely.
Flags: needinfo?(tbsaunde+mozbugs) → needinfo?(aryx.bugmail)
Whiteboard: aes+
Trevor what's next here? Should we wait to see what dparks comes up with?
Flags: needinfo?(tbsaunde+mozbugs)
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(tbsaunde+mozbugs)
Resolution: --- → FIXED
Are we good for 54 here? It's not at all clear to me what fixed this bug.
Flags: needinfo?(dbolter)
Yes we're good. No 54 crashes since 20170228030203. The source fix was in another bug.
Flags: needinfo?(dbolter)
Assignee: nobody → tbsaunde+mozbugs
You need to log in before you can comment on or make changes to this bug.