Chrome process content become black or flickering

RESOLVED INVALID

Status

()

Core
Graphics: WebRender
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: sotaro, Assigned: sotaro)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
On graphics branch, chrome process content become black or flickering.
(Assignee)

Comment 1

a year ago
It seemed to caused by a conflict of Bug 1339625 fix and Bug 1337885 fix.

On Bug 1339625, we did not change to ContentClientDoubleBuffered and keep ContentClientSingleBuffered usage. Further, release TextureHost to unlock read lock.

But there could be a case that WebRenderPaintedLayer is recompositted without repaint. Bug 1337885 fix seemed to make it very often.
(Assignee)

Comment 2

a year ago
We did not choose ContentClientDoubleBuffered to not increase memory usage, since rendering of ExternalImage is not optimum. But since this bug, we could not avoid temporary memory usage increase. The increase could be addressed when we have optimum ExternalImage rendering path.
(Assignee)

Updated

a year ago
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Updated

a year ago
Blocks: 1311790
(Assignee)

Updated

a year ago
Blocks: 1339625
(Assignee)

Updated

a year ago
Blocks: 1337885
(Assignee)

Comment 3

a year ago
Created attachment 8839038 [details] [diff] [review]
patch - Enable double buffering on WebRenderPaintedLayer
(Assignee)

Updated

a year ago
Attachment #8839038 - Attachment description: patch - Enable double buffering → patch - Enable double buffering on WebRenderPaintedLayer
Attachment #8839038 - Attachment is patch: true
Attachment #8839038 - Attachment mime type: text/x-patch → text/plain
(Assignee)

Comment 4

a year ago
Bug 1340953 is created for reducing memory usage of WebRenderPaintedLayer.
I think this is the same as bug 1340798
See Also: → bug 1340798
(Assignee)

Comment 6

a year ago
Even with double buffering, reftest orange did not addressed.

 https://treeherder.mozilla.org/#/jobs?repo=try&revision=0bef014e6932d1be93922071260e8fbd7158ce29
(Assignee)

Comment 7

a year ago
(In reply to Sotaro Ikeda [:sotaro] from comment #6)
> Even with double buffering, reftest orange did not addressed.
> 
>  https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=0bef014e6932d1be93922071260e8fbd7158ce29

From bug 1340798 comment10, oranges were caused by Bug 1337885.
(Assignee)

Updated

a year ago
Attachment #8839038 - Flags: review?(nical.bugzilla)
(Assignee)

Comment 8

a year ago
(In reply to (away until Feb21) Kartikaya Gupta (email:kats@mozilla.com) from comment #5)
> I think this is the same as bug 1340798

By bug 1340798 comment10, this bug is different than bug 1340798.
(Assignee)

Updated

a year ago
Blocks: 1340953
(Assignee)

Comment 9

a year ago
bug 1337885 was backed out, then the flickering does not happen now. But it is necessary for bug 1337885.
Comment on attachment 8839038 [details] [diff] [review]
patch - Enable double buffering on WebRenderPaintedLayer

Review of attachment 8839038 [details] [diff] [review]:
-----------------------------------------------------------------

I think that in today's meeting you and Morris talked about using ImageClient/Host for content. Does it affect this patch?
(Assignee)

Comment 11

a year ago
Comment on attachment 8839038 [details] [diff] [review]
patch - Enable double buffering on WebRenderPaintedLayer

It becomes not necessary
Attachment #8839038 - Flags: review?(nical.bugzilla)
(Assignee)

Comment 12

a year ago
(In reply to Sotaro Ikeda [:sotaro] from comment #11)
> Comment on attachment 8839038 [details] [diff] [review]
> patch - Enable double buffering on WebRenderPaintedLayer
> 
> It becomes not necessary

By Bug 1341001.
(Assignee)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.