Assertion failure: mightHaveNoneSVGMask || aFrame->GetParent()->StyleContext()->GetPseudo() == nsCSSAnonBoxes::mozAnonymousBlock (How did we getting here, then?), at nsSVGIntegrationUtils.cpp:135

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: cbook, Unassigned)

Tracking

(Blocks 1 bug, {assertion})

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54- wontfix)

Details

()

Attachments

(2 attachments)

Posted file bughunter stack
Assertion failure: mightHaveNoneSVGMask || aFrame->GetParent()->StyleContext()->GetPseudo() == nsCSSAnonBoxes::mozAnonymousBlock (How did we getting here, then?), at c:/builds/moz2_slave/m-cen-w32-d-000000000000000000/build/src/layout/svg/nsSVGIntegrationUtils.cpp:135

found via bughunter and reproduced on latest m-c tinderbox windows debug trunk build on windows 7.

Seems also affect linux so setting platform to all

Steps to reproduce:
-> Load https://www.ibtec.com.ua/
--> Assertion on load
[Tracking Requested - why for this release]:
bughunter live site result

Cameron, cjku could you take a look, thanks!
Flags: needinfo?(cku)
Flags: needinfo?(cam)
note: we have problems on this site also on beta and aurora - but there is seems the assertion is not fatal

[328] ###!!! ASSERTION: How did we getting here, then?: 'aFrame->GetParent()->StyleContext()->GetPseudo() == nsCSSAnonBoxes::mozAnonymousBlock', file c:/builds/moz2_slave/m-beta-w32-d-00000000000000000/build/src/layout/svg/nsSVGIntegrationUtils.cpp, line 115

and we crash later with 

Assertion failure: aSurface ? aSurfaceRect.Size() == aSurface->GetSize() : aSurfaceRect.IsEmpty(), at c:/builds/moz2_slave/m-beta-w32-d-00000000000000000/build/src/gfx/2d/FilterNodeSoftware.cpp:400

on beta and aurora
See Also: → 1340994
filed bug 1340994 for the aurora/beta issue
Assignee: nobody → cku
Flags: needinfo?(cku)
(In reply to Carsten Book [:Tomcat] from comment #2)
> note: we have problems on this site also on beta and aurora - but there is
> seems the assertion is not fatal
> 
> [328] ###!!! ASSERTION: How did we getting here, then?:
> 'aFrame->GetParent()->StyleContext()->GetPseudo() ==
> nsCSSAnonBoxes::mozAnonymousBlock', file
> c:/builds/moz2_slave/m-beta-w32-d-00000000000000000/build/src/layout/svg/
> nsSVGIntegrationUtils.cpp, line 115
> 
> and we crash later with 
> 
> Assertion failure: aSurface ? aSurfaceRect.Size() == aSurface->GetSize() :
> aSurfaceRect.IsEmpty(), at
> c:/builds/moz2_slave/m-beta-w32-d-00000000000000000/build/src/gfx/2d/
> FilterNodeSoftware.cpp:400
> 
> on beta and aurora

So, on central we crash at
Assertion failure: mightHaveNoneSVGMask || aFrame->GetParent()->StyleContext()->GetPseudo() == nsCSSAnonBoxes::mozAnonymousBlock

on beta and aurora, we crash later on 
Assertion failure: aSurface ? aSurfaceRect.Size() == aSurface->GetSize()
For debugging purpose, we can temporary remove the assertion in nsSVGIntegrationUtils.cpp
Assertion failure: mightHaveNoneSVGMask || aFrame->GetParent()->StyleContext()->GetPseudo() == nsCSSAnonBoxes::mozAnonymousBlock (How did we getting here, then?), at c:/builds/moz2_slave/m-cen-w32-d-000000000000000000/build/src/layout/svg/nsSVGIntegrationUtils.cpp:135

Then, the behavior of loading this page on central aligns aurora/beta.... page keep loading with no response.
If I can't find out root cause and fix it soon, I think it's better temporary roll MOZ_ASSERT back to NS_ASSERTION unless anyone disagree.
Pushed by cku@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9d5a1af816e9
Demote MOZ_ASSERT to NS_ASSERTION before root cause addressed. r=me
Keywords: leave-open
now the behavior of central is align with beta/aurora.
See Also: → 1340257
I will deassign this bug from me and fix the assertion in bug 1340257.(root cause of hitting this assertion: bug 1340257 comment 2).
Even we fix that assertion, FF still can not load this page completely.
To one who is going to work on this bug, please manually apply the 1st patch in bug 1336480(before it's landed in central).
Assignee: cku → nobody
Flags: needinfo?(cam)
Posted file testcase.html
Simpler test case to reproduce the problem.
Works on MacOS 10.12.2 Nightly debug build with commit id d84beb192e57e26846c82d3df3599381f4663792.
(In reply to Kevin Chen[:kechen] (UTC + 8) from comment #11)
> Created attachment 8839899 [details]
> testcase.html
> 
> Simpler test case to reproduce the problem.
> Works on MacOS 10.12.2 Nightly debug build with commit id
> d84beb192e57e26846c82d3df3599381f4663792.

Already being fixed by the patches in bug 1340257
Can this be closed now?
Flags: needinfo?(cku)
Not yet, there are several issues here.
1. assertion failure: fixed in bug 1340257
2. Allocation failure: fixed in bug 1336480
3. Can not load this page completely: not fix yet

We still need to handle #3 in this bug
Flags: needinfo?(cku)
Hi Kevin, I saw your comment in Bug 1340994 comment 10. Could you also verify this bug on central?
Flags: needinfo?(kechen)
I think they've updated the web page, I cannot reproduce the assertion failure even I rollback to previous version of m-c.
This web page can be correctly loaded right now.
Flags: needinfo?(kechen)
Thanks Kevin.
I think we can close this bug now
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Per commant #16, track 54- and mark 54 won't fix.
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.