hotmail fails to delete successive emails. "Hotmail responded: Some of the requested messages no longer exist"

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
2 years ago
11 months ago

People

(Reporter: jd31068, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

deleting email from my Hotmail account, when deleting a few in a row Thunderbird displays a small popup "The current operation on Inbox did not succeed" Then saying the message was not found. At which point the message reappears, and I have to delete it again.


Actual results:

Timestamp: 2/21/2017 11:01:30 AM
Error: uncaught exception: 2147746065
Source File: resource:///modules/activity/autosync.js
Line: 210


Expected results:

I shouldn't have to delete an email more than once :)
(Reporter)

Updated

2 years ago
Keywords: 64bit
(Reporter)

Comment 1

2 years ago
Created attachment 8839611 [details]
Popup message

I deleted some emails quickly from Hotmail inbox

Comment 2

2 years ago
I have a similar issue. In the Activity Manager, I get
The current operation on 'Inbox' did not succeed. The mail server for account Outlook.Com responded: Some of the requested messages no longer exist.

User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:45.0) Gecko/20100101 Thunderbird/45.7.1

Comment 3

2 years ago
the autosync item in error console is normal (I do wish we would get rid of it)

sounds like a server issue to me.
are you still seeing it?
Flags: needinfo?(jd31068)
Whiteboard: [closeme 2017-04-01]
(Reporter)

Comment 4

2 years ago
Yes, I am, multiple times a day. I am not sure that the error console message is connected. Though it does seem to be listed after it happens.

What else can I do to help?

Comment 5

2 years ago
Just tested this again and same issue.  The notification pop-up appears at the lower right of the Thunderbird window.

Steps to reproduce (likely other ways too):

1. You need a Hotmail/Outlook.com IMAP account that has a folder containing about 20 to 40 contiguous email messages you want to delete.  ** Make sure you're using a Hotmail account for this test!!! **

2. Highlight the first message.
3. Press delete, at least once every second, to delete 20 to 30 messages in succession.
4. Stop and pay attention to the bottom of the Thunderbird window, for the pop-up.  There can be several seconds delay before the message appears
5. Once you see the pop-up, also look in Error Console for the autosync.js exception message.

Comment 6

2 years ago
(In reply to IU from comment #5)
> Just tested this again and same issue. 

I don't think this is our problem.

Are you the same person as "Jon"?
Flags: needinfo?(jd31068)
Summary: hotmail fails to delete successive emails → hotmail fails to delete successive emails. "Hotmail responded: Some of the requested messages no longer exist"
Whiteboard: [closeme 2017-04-01]
(Reporter)

Comment 7

2 years ago
Nope, I'm Jon :)
I am still experiencing this as well as of yesterday.

For what it is worth, I decided to try emClient as well. I'm not having the problem with it. They recommend using their "exchange services" account instead of IMAP with hotmail/outlook.com accounts these days.

This may have been due to MS changing some server behaviors? They didn't expound on their reason for the new setup; at least not in the thread, I read the new recommendation in.

I used to be a developer (I'm disabled now) I'll help any way I can. If you'd like for me to run some debug version to grab some logs I'd be happy to.

Thanks for checking in and for all y'alls efforts in Thunderbird

Comment 8

2 years ago
(64bit keyword is for issues that exist only in 64bit world, i.e. don't occur in the 32bit world)
Keywords: 64bit

Comment 9

11 months ago
(In reply to Jon from comment #7)
> ...
> I used to be a developer (I'm disabled now) I'll help any way I can. If
> you'd like for me to run some debug version to grab some logs I'd be happy
> to.

Thanks for the offer. Do you still see this in version 52?
Flags: needinfo?(jd31068)

Comment 10

11 months ago
We'd like to help you. But more information is required from you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(jd31068)
Resolution: --- → INCOMPLETE
(Reporter)

Comment 11

11 months ago
(In reply to Wayne Mery (:wsmwk) from comment #10)
> We'd like to help you. But more information is required from you.

Sorry, it's been a busy couple of weeks with the holidays. I'll reinstall Thunderbird, I moved on to EM Client because of the delete issue and I like being able to delete an email from the new email popup. Give me a couple of days to test it out 
(Reporter)

Comment 12

11 months ago
ok, after updating from 45 to 52.5.2 and dealing with finicky google calendar provider (#Offtopic) I let my Hotmail junk folder get 10 emails in it and was able to rapidly delete them without issue. 

Man, I missed Thunderbird.  I'll continue to bang on it. Previously it would not allow even 3 to be deleted like that. 
You need to log in before you can comment on or make changes to this bug.