comboboxes don't resize vertically when user changes font size

RESOLVED DUPLICATE of bug 62384

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 62384
16 years ago
16 years ago

People

(Reporter: Christopher Whitt, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Reproducibility: Always

Seen on build 2002032709, but it's probably been around a while.

Steps to reproduce:
1. Open any page with comboboxes (ie bugzilla query)
2. Use text zoom to change to an extreme setting (CTRL++ or View->Text
Zoom->Larger several times)
3. Observe combo boxes have not changed height.

The problem is not very visible when you open a page with normal font sizes, but
it's much worse if you set your fonts unusually small before opening a page with
comboboxes.

This can force combobox content to be impossible to read until you select the
control.  I came across this problem when I accidentally used the new mouse
scroll wheel setting to change the font size to a very small setting, then
reloaded the query page.  When I restored the font to a normal size, all of the
comboboxes stayed at the small extremely small height.

If the user doesn't realize they can click each box to see its contents, they
might reload and lose any form information they've entered.  Could this also be
an accessibility issue?

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 62384 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.