Closed Bug 62384 Opened 19 years ago Closed 15 years ago

[MF][CBX] Text Zoom and Minimum font size doesn't change dropdown height (without reload)

Categories

(Core :: Layout: Form Controls, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Future

People

(Reporter: jlbec, Assigned: roc)

References

Details

(Whiteboard: [Hixie-P0] obsoleted by XBL form controls)

Attachments

(3 files, 1 obsolete file)

Take the browser to a page that contains dropdown lists (eg, espn.go.com).  This
would be single line <SELECT> elements.  If you then change the text size with
View->Text Size, the dropdown list widgets do not change size with the text.
This can result in the text being way to big or small for the widget.
->html form controls
Component: XP Toolkit/Widgets → HTML Form Controls
really
Assignee: trudelle → rods
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: jrgm → bsharma
The combobox is optimizing away the style change reflow, in this case it needs 
to do a full reflow.
Status: NEW → ASSIGNED
Priority: P3 → P1
Summary: Changing View->Text Size doesn't change dropdown list size → [MF][CBX]Changing View->Text Size doesn't change dropdown list size
Set milestone to mozilla0.8
Target Milestone: --- → mozilla0.8
Changing milestone from mozilla0.8 to mozilla0.9
Target Milestone: mozilla0.8 → mozilla0.9
Marking future.
Target Milestone: mozilla0.9 → Future
Blocks: 47275
is this a duplicate of bug 54691?  Or separate?
QA Contact Update
QA Contact: bsharma → vladimire
*** Bug 71578 has been marked as a duplicate of this bug. ***
*** Bug 80695 has been marked as a duplicate of this bug. ***
*** Bug 105012 has been marked as a duplicate of this bug. ***
As you may see in my duplicate report, this is Platform->All. 
*** Bug 110462 has been marked as a duplicate of this bug. ***
*** Bug 115444 has been marked as a duplicate of this bug. ***
OS: Linux → All
Hardware: PC → All
Platform/OS -> All/All
*** Bug 100856 has been marked as a duplicate of this bug. ***
Priority: P1 → P3
Summary: [MF][CBX]Changing View->Text Size doesn't change dropdown list size → [MF][CBX] Text Zoom doesn't change dropdown list size
*** Bug 129793 has been marked as a duplicate of this bug. ***
This works properly with XBL form controls.
*** Bug 54504 has been marked as a duplicate of this bug. ***
*** Bug 47275 has been marked as a duplicate of this bug. ***
*** Bug 134179 has been marked as a duplicate of this bug. ***
I am putting some nominations on this sucker, because it's got a *lot* of dups,
and it's an accessibility issue. Rods, can you please reconsider the "Future"
target milestone?

Also fixing summary to be better (show up in more queries).
Keywords: mozilla1.1, nsbeta1
Summary: [MF][CBX] Text Zoom doesn't change dropdown list size → [MF][CBX] Text Zoom doesn't change dropdown height (without reload)
hwaara: see comment #18.  XBL Form Controls are planned to be turned on in 1.0
branch as well as trunk.  Any UI issues fixed by XBL Form Controls is getting
lower priority due to this.
nsbeta1-. Engineers are overloaded with higher priority bugs and this issue will
be fixed by XBL form elements.
Keywords: nsbeta1nsbeta1-
*** Bug 137941 has been marked as a duplicate of this bug. ***
XBL form controls aren't making it in to 1.0.  Should we reconsider this bug?
*** Bug 138468 has been marked as a duplicate of this bug. ***
*** Bug 138591 has been marked as a duplicate of this bug. ***
*** Bug 145617 has been marked as a duplicate of this bug. ***
*** Bug 143306 has been marked as a duplicate of this bug. ***
Is anyone working on a fix for this?
Could it be moved closer than Future?
JG
This is fixed in the XBL form controls, that will hopefully be on by default in
1.1 or so (I don't know the exact target milestone).
*** Bug 150861 has been marked as a duplicate of this bug. ***
*** Bug 153076 has been marked as a duplicate of this bug. ***
A bug I reported this morning (bug 153076) included list boxes (select tags with
size greater than 1).  It got marked a dup of this one, but I see only
single-line selects mentioned here.  Should I open another bug mentioning just
list boxes?  And will the XBL form controls fix the list box text zoom problem too?
Hi Brian,
Thanks for the infomation.

maybe you could file one with a dependency on this one or we could add yours to
this one?
what does everyone else think?
JG
*** Bug 165528 has been marked as a duplicate of this bug. ***
*** Bug 163649 has been marked as a duplicate of this bug. ***
*** Bug 172795 has been marked as a duplicate of this bug. ***
Keywords: mozilla1.1
*** Bug 175563 has been marked as a duplicate of this bug. ***
*** Bug 177288 has been marked as a duplicate of this bug. ***
*** Bug 182518 has been marked as a duplicate of this bug. ***
*** Bug 182436 has been marked as a duplicate of this bug. ***
*** Bug 184812 has been marked as a duplicate of this bug. ***
*** Bug 191395 has been marked as a duplicate of this bug. ***
*** Bug 192372 has been marked as a duplicate of this bug. ***
Whiteboard: [Hixie-P0] obsoleted by XBL form controls
*** Bug 184186 has been marked as a duplicate of this bug. ***
*** Bug 208963 has been marked as a duplicate of this bug. ***
*** Bug 209035 has been marked as a duplicate of this bug. ***
*** Bug 209047 has been marked as a duplicate of this bug. ***
Updating description, this applies to changing the min font size too.
Summary: [MF][CBX] Text Zoom doesn't change dropdown height (without reload) → [MF][CBX] Text Zoom and Minimum font size doesn't change dropdown height (without reload)
*** Bug 211447 has been marked as a duplicate of this bug. ***
Attached patch patch (obsolete) — Splinter Review
When a line of <select> elements is zoomed, in the function of
nsComboboxControlFrame::ReflowCombobox(), the value of 'mCacheSize.height' has
previous height of the combobox, but the value of 'aFallBack' has current
height.
*** Bug 213048 has been marked as a duplicate of this bug. ***
Attachment #127453 - Flags: review?(john)
*** Bug 214251 has been marked as a duplicate of this bug. ***
What's the point of mCacheSize.height if you never plan to use it?  The right
fix here is to clear the size cache when the style data gets blown away due to
the font zoom or to fix the performance issues that necessitated the cached size
in the first place.

Alternately, you could ignore the cache based on the type of reflow you are
getting (assuming that zooming does a stylechange reflow instead of an
incremental one).

In any case, the patch as posted here would lead to some serious perf issues, if
I understand the motivation behind the original size caching correctly.
See also bug 218700, "adding options to SELECT doesn't increase height to
accomodate new options".
*** Bug 219660 has been marked as a duplicate of this bug. ***
*** Bug 226624 has been marked as a duplicate of this bug. ***
*** Bug 228455 has been marked as a duplicate of this bug. ***
I put a picture of the (my) problem as an attachment.

This bug has gotten a lot of dupes (I filed the newest one). I would suggest
clarifying the summary. Right now the summary doesn't reflect the bug very well
as stated in the original bugreport or how it is described in the dupes.

The problem as I have experienced it, is not with the dropdown list's height,
but with the unopened combobox' height. The dropdown _list_ looks just fine. 

How about at least putting the words combobox and resize in the summary?
Actually, Mikko, the dropdown _list_ is not fine either.

Look on the attachment of bug 175563.
Attachment #127453 - Flags: review?(john)
*** Bug 238580 has been marked as a duplicate of this bug. ***
OK, I'll take this.

Can someone attach a testcase that reliably reproduces this bug? Because it
seems to work OK for me. Even when the dropdown is showing! (Although that
triggers a fun bug that next time you resize the fontsize, the dropdown pops up
again ... which can lead to multiple dropdowns showing at once)
Assignee: rods → roc
Status: ASSIGNED → NEW
*** Bug 244710 has been marked as a duplicate of this bug. ***
Can I ask what is the status of this bug?
*** Bug 258483 has been marked as a duplicate of this bug. ***
Attached patch patchSplinter Review
Attachment #127453 - Attachment is obsolete: true
Attachment #160151 - Flags: review?(roc)
I think that the cached height should be reset, if the cached height is not
equal to the current height in the cause of using the Text Zoom.
Comment on attachment 160151 [details] [diff] [review]
patch

I don't fully understand this code, but no-one does, and to the limits of my
understanding, this looks good.
Attachment #160151 - Flags: superreview+
Attachment #160151 - Flags: review?(roc)
Attachment #160151 - Flags: review+
roc, please check into the trunk.
checked in. Thanks Hideo!
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
*** Bug 218700 has been marked as a duplicate of this bug. ***
IIRC FF suffers from the same issue. Once this is verified, can the patch be
checked into aviary branch as well?
Flags: blocking-aviary1.0?
not serious enough to block.
Flags: blocking-aviary1.0? → blocking-aviary1.0-
Comment on attachment 160151 [details] [diff] [review]
patch

I agree this isn't a blocker, but seems safe enough to approve anyway. Has at
least 41 dupes I can see
Attachment #160151 - Flags: approval1.7.x?
Attachment #160151 - Flags: approval-aviary?
Comment on attachment 160151 [details] [diff] [review]
patch

a=asa for aviary and 1.7 checkin.
Attachment #160151 - Flags: approval1.7.x?
Attachment #160151 - Flags: approval1.7.x+
Attachment #160151 - Flags: approval-aviary?
Attachment #160151 - Flags: approval-aviary+
*** Bug 270738 has been marked as a duplicate of this bug. ***
*** Bug 271339 has been marked as a duplicate of this bug. ***
*** Bug 282922 has been marked as a duplicate of this bug. ***
This problem still appears in version 2.0-rc3 on WinXP. The attached screenshot was taken at 144 dpi, but the same problem exists at 96 dpi too, only a bit less dramatic.
Note that I only get this effect when pressing Ctrl++ *twice*.
This bug is fixed only on trunk. See the state of this bug.
(In reply to comment #83)
> This bug is fixed only on trunk. See the state of this bug.
> 

Oops, sorry, this bug fixed before Gecko1.8, if you find a similar bug, that is a new bug. So, please file a new bug. Don't comment to the closed bugs.
Ok, filed new bug 356952
You need to log in before you can comment on or make changes to this bug.