Closed Bug 1342333 Opened 3 years ago Closed 2 years ago

Remove any use of nsIURLClassifier.classifyLocalWithTables on the main thread

Categories

(Toolkit :: Safe Browsing, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1515272

People

(Reporter: hchang, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: perf, Whiteboard: [qf:meta])

It appears many uses of nsIURLClassifier.classifyLocalWithTables are on main thread and the function is synchronous. We should remove all of them. Works also include the IPC counter part.
Assignee: nobody → hchang
Summary: Remove any use of nsIURLClassifier.classifyLocalWithTables → Remove any use of nsIURLClassifier.classifyLocalWithTables on the main thread
Given that the implementation of nsIURLClassifier.classifyLocalWithTables() [1] forces it to be called
on the main thread, we may in the end just remove this function.

[1] http://searchfox.org/mozilla-central/source/toolkit/components/url-classifier/nsUrlClassifierDBService.cpp#1634
Blocks: SyncIPC
Depends on: 1325054
Status: NEW → ASSIGNED
Priority: -- → P2
Depends on: 1343425, 1345058
Depends on: 1341506
Whiteboard: [qf:meta]
Assignee: hchang → nobody
Status: ASSIGNED → NEW
We don't have any solution for this at this moment.
Put it to the backlog.
Priority: P2 → P5
Whiteboard: [qf:meta] → [qf:meta][sb-backlog]
Henry, please add some comments for a detailed explanation.
Flags: needinfo?(hchang)
Backlog is P3.
Priority: P5 → P3
Whiteboard: [qf:meta][sb-backlog] → [qf:meta]
We wanted to remove all uses of the sync API: nsIURLClassifier.classifyLocalWithTables
and bug 1345058 used to be the last mile until we figured out we are unable to totally
get rid of it without an enormous work. 

We are taking the sub-optimal solution which will decrease the probability of using this API. 
In other words, fixing bug 1345058 doesn't mean we can remove the sync API.
Flags: needinfo?(hchang)
Keywords: perf
Depends on: 1514202

The synchronous API is removed in Bug 1515272 because of fantastic work was done by baku in Bug 1514202.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1515272
You need to log in before you can comment on or make changes to this bug.