The default bug view has changed. See this FAQ.

Revert stub installer default from 64-bit to 32-bit on Aurora 54

RESOLVED FIXED

Status

()

Firefox
Installer
P1
normal
RESOLVED FIXED
a month ago
13 days ago

People

(Reporter: cpeterson, Assigned: mhowell)

Tracking

(Blocks: 1 bug)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 wontfix, firefox52 wontfix, firefox53 wontfix, firefox54 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

a month ago
+++ This bug was initially created as a clone of Bug #1338583 +++

We must postpone our 64-bit rollout again, now from Firefox 54 to 55 because Farmville 2 will be broken on 64-bit without async drawing (bug 1317995), but we can't enable async drawing until bug 1323403 and bug 1336517 are fixed. So we must revert 54's stub installer default from 64-bit to 32-bit.

Let's wait until 54 is in Aurora so we don't need to change the installer default back to 64-bit in Nightly 55.
(Assignee)

Comment 1

22 days ago
Created attachment 8844981 [details] [diff] [review]
Disable 64-bit as default for new installs

This patch is identical to bug 1338583, just rebased for current aurora (and re-tested manually), so carrying over r+. I'll also copy over the same uplift request. As before, note that this patch is not intended to land in nightly 55, only aurora 54.

Approval Request Comment

[Feature/Bug causing the regression]:
See comment 0

[User impact if declined]:
Misbehavior or outright failure of popular Flash applications

[Is this code covered by automated tests?]:
No

[Has the fix been verified in Nightly?]:
No, it's not intended for or needed on nightly

[Needs manual test from QE? If yes, steps to reproduce]:
No, I've tested it manually

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
It's a very small and focused change, and I've manually verified it

[String changes made/needed]:
None
Attachment #8844981 - Flags: review+
Attachment #8844981 - Flags: approval-mozilla-aurora?
Comment on attachment 8844981 [details] [diff] [review]
Disable 64-bit as default for new installs

32bit by default for 54 stub installer

Looking forward to 55 when we can hopefully go 64bit finally :)
Attachment #8844981 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 3

16 days ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/efbf7a1aff27
status-firefox54: affected → fixed
(Reporter)

Comment 4

13 days ago
Resolving as fixed because Matt's patch landed on Aurora in comment 3.
Status: NEW → RESOLVED
Last Resolved: 13 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.