TIAS issues with the webrtc49 update (FF53+)

RESOLVED FIXED in Firefox 54

Status

()

defect
P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jesup, Assigned: jesup)

Tracking

(Depends on 1 bug)

52 Branch
mozilla54
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox54 fixed)

Details

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1332031 +++

The report this is cloned from discussed getting no video in 53 with TIAS.  While investigating another bug, I hit assertions that indicated that there was a kbps vs bps bug in VideoConduit.cpp with TIAS.

To solve the issue, and avoid future ones, I've finished the conversion of all vars in VideoConduit to bps.
Attachment #8841293 - Flags: review?(drno)
Blocks: 1337777
Try run in bug 1337777
Comment on attachment 8841293 [details] [diff] [review]
Handle all bitrates in VideoConduit as bps, instead of mix of kbps and bps

Review of attachment 8841293 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8841293 - Flags: review?(drno) → review+

Comment 4

2 years ago
Pushed by rjesup@wgate.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/101f277fa881
Handle all bitrates in VideoConduit as bps, instead of mix of kbps and bps r=drno

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/101f277fa881
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Blocks: 1359854
You need to log in before you can comment on or make changes to this bug.