Closed Bug 1342727 Opened 4 years ago Closed 4 years ago

TIAS issues with the webrtc49 update (FF53+)

Categories

(Core :: WebRTC: Networking, defect, P2)

52 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla54
Tracking Status
firefox54 --- fixed

People

(Reporter: jesup, Assigned: jesup)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1332031 +++

The report this is cloned from discussed getting no video in 53 with TIAS.  While investigating another bug, I hit assertions that indicated that there was a kbps vs bps bug in VideoConduit.cpp with TIAS.

To solve the issue, and avoid future ones, I've finished the conversion of all vars in VideoConduit to bps.
Attachment #8841293 - Flags: review?(drno)
Blocks: 1337777
Try run in bug 1337777
Comment on attachment 8841293 [details] [diff] [review]
Handle all bitrates in VideoConduit as bps, instead of mix of kbps and bps

Review of attachment 8841293 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8841293 - Flags: review?(drno) → review+
Pushed by rjesup@wgate.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/101f277fa881
Handle all bitrates in VideoConduit as bps, instead of mix of kbps and bps r=drno
https://hg.mozilla.org/mozilla-central/rev/101f277fa881
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
Blocks: 1359854
You need to log in before you can comment on or make changes to this bug.