Fix macosx64's release-l10n for invalid entries and update debug mozconfig to include --enable-calendar

RESOLVED FIXED in seamonkey2.51

Status

defect
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

(Blocks 1 bug)

Trunk
seamonkey2.51
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.50 fixed, seamonkey2.51 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Currently, in all trees, macosx64/release-l10n is bad (we have never
used macosx64/release-l10n as we used macosx-universal/release-l10n.

However, with the dropping of universal builds, we need to fix
the macosx64/release-l10n as the following need to be replaced:


if [ "$MOZ_UPDATE_CHANNEL" == "beta" ]; then
  ac_add_options --with-l10n-base=../../releases/l10n/mozilla-beta
fi;
if [ "$MOZ_UPDATE_CHANNEL" == "release" ]; then
  ac_add_options --with-l10n-base=../../releases/l10n/mozilla-release
fi;
Blocks: 1329379
macosx64 release-l10n is old (and was never used).. updating to reflect
the required entries.
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #8841397 - Flags: review?(frgrahl)
This patch needs to be uplifted to c-a only as c-b and c-r are still using
universal builds.
Summary: Fix macosx64's release-l10n for invalid entries → Fix macosx64's release-l10n for invalid entries and update debug mozconfig to include --enable-calendar
Attachment #8841397 - Attachment is obsolete: true
Attachment #8841397 - Flags: review?(frgrahl)
Attachment #8841446 - Flags: review?(frgrahl)
Comment on attachment 8841446 [details] [diff] [review]
[mozconfigs] update osx64 release-l10n and debug

[Approval Request Comment]
Regression caused by (bug #): 1329379
User impact if declined: no l10n OSX builds 
Testing completed (on m-c, etc.): c-c  
Risk to taking this patch (and alternatives if risky): none 
String changes made by this patch:
Attachment #8841446 - Flags: review?(frgrahl)
Attachment #8841446 - Flags: review+
Attachment #8841446 - Flags: approval-comm-aurora?
Blocks: SM2.48b1
Comment on attachment 8841446 [details] [diff] [review]
[mozconfigs] update osx64 release-l10n and debug

a=me for c-a
Attachment #8841446 - Flags: approval-comm-aurora? → approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/aa1515f719f903be4d59d8137d67629fc33bb7aa
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.51
Version: unspecified → Trunk
Blocks: SM2.48
You need to log in before you can comment on or make changes to this bug.