warning: No effect for `llabs(unsigned)` in MP4Metadata.cpp

RESOLVED DUPLICATE of bug 1342339

Status

()

RESOLVED DUPLICATE of bug 1342339
2 years ago
2 years ago

People

(Reporter: gerald, Assigned: ayang)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
6 new warnings introduced by bug 1340446, on Linux and Mac:
> Warning: -Wabsolute-value in media/libstagefright/binding/MP4Metadata.cpp: taking the absolute value of unsigned type 'unsigned long long' has no effect
> INFO -  media/libstagefright/binding/MP4Metadata.cpp:377:29: warning: taking the absolute value of unsigned type 'unsigned long long' has no effect [-Wabsolute-value]
> INFO -        MOZ_DIAGNOSTIC_ASSERT(llabs(data.indices[i].start_composition - aDest[i].start_composition) <= 1);
> INFO -                              ^

Alfredo, could you please have a look when possible?
(Assignee)

Comment 1

2 years ago
(In reply to Gerald Squelart [:gerald] from comment #0)
> 6 new warnings introduced by bug 1340446, on Linux and Mac:
> > Warning: -Wabsolute-value in media/libstagefright/binding/MP4Metadata.cpp: taking the absolute value of unsigned type 'unsigned long long' has no effect
> > INFO -  media/libstagefright/binding/MP4Metadata.cpp:377:29: warning: taking the absolute value of unsigned type 'unsigned long long' has no effect [-Wabsolute-value]
> > INFO -        MOZ_DIAGNOSTIC_ASSERT(llabs(data.indices[i].start_composition - aDest[i].start_composition) <= 1);
> > INFO -                              ^
> 
> Alfredo, could you please have a look when possible?

Yes, it's on bug 1342339.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1342339
You need to log in before you can comment on or make changes to this bug.