Closed Bug 1343107 Opened 3 years ago Closed 3 years ago

Stop using tc-vcs based images

Categories

(Release Engineering :: Release Automation: Other, defect, P1)

defect

Tracking

(firefox54 fixed)

RESOLVED FIXED
Tracking Status
firefox54 --- fixed

People

(Reporter: rail, Assigned: rail)

References

Details

Attachments

(3 files)

in bug 1343104 we hit an issue where we had no tc-vcs images for mozilla-esr52, so at least 2 types of tasks failed:

1) source generation
2) docker image generation

We should revise those tasks and make sure we use newer images with robustcheckout
I can look at this sometimes this/next week.
Assignee: nobody → rail
Priority: -- → P1
I briefly looked at the current implementation and it looks like we need to implement "taskcluster-build-image" and move our images to https://dxr.mozilla.org/mozilla-central/source/taskcluster/docker/

Also need to update releasetasks to use the new image and fix/add env variables:
* Add IMAGE_NAME
* Prepend hg related env vars with GECKO_
* use default command (no need to pass one)
Pushed this to jamun https://hg.mozilla.org/projects/jamun/rev/566f1645544684b3eb7484719f050c53fcccaf54

I also need to update releasetasks to use the newer image
Attached file PR
Example run: https://tools.taskcluster.net/task-inspector/#Qp1og4bWQe6OMsm3QzBEVQ/

I'm going to start a jamun-based release to make sure everything works as expected before I deploy this.
Attachment #8843133 - Flags: review?(nthomas)
Comment on attachment 8843135 [details]
Bug 1343107 - Fix linter failures  a=release

https://reviewboard.mozilla.org/r/116902/#review118536
Attachment #8843135 - Flags: review?(nthomas) → review+
Attachment #8843133 - Flags: review?(nthomas) → review+
Comment on attachment 8843133 [details] [review]
PR

Deployed
Attachment #8843133 - Flags: checked-in+
Pushed by raliiev@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f65f60dc44c2
Move release images under taskcluster/docker r=nthomas a=release
Still need to uplift this to aurora, release and esr45
Attachment #8843135 - Flags: review+ → review?(nthomas)
Comment on attachment 8843135 [details]
Bug 1343107 - Fix linter failures  a=release

https://reviewboard.mozilla.org/r/116902/#review118576
Attachment #8843135 - Flags: review?(nthomas) → review+
Pushed by raliiev@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7217c21ffbc2
Fix linter failures r=nthomas a=release
Comment on attachment 8843239 [details]
Bug 1343107 - Fix docker image location on esr52  a=release

https://reviewboard.mozilla.org/r/117030/#review118622

Thanks!
Attachment #8843239 - Flags: review?(jcristau) → review+
A little bit more of context regarding attachment 8843239 [details]. 52.0esr build 3 failed because of [1]. The root cause is: {beetmover, funsize} images have been moved to taskcluster/docker instead of testing/docker. The reason behind the confusion is the following: on jamun every image is under taskcluster/docker, whereas on esr52, they live under testing/docker.

Thanks to jcristau's help, we decided to put every image at the same directory, which is testing/docker on ESR52. This landed on esr52 at: https://hg.mozilla.org/releases/mozilla-esr52/rev/9ddc2f6bc37d8a4eab32c59823e11d2b4d68d61e

This change requires to spin a build number 4.

[1] https://tools.taskcluster.net/task-group-inspector/#/h_8hgEwSTeWCV40FReICaw/OYhxrEqzTuiGNm6vFI9nKg?_k=6ch43e
You need to log in before you can comment on or make changes to this bug.