Crash when terminating the GPU process while playing a video on social media

RESOLVED DUPLICATE of bug 1331761

Status

()

Core
Graphics
P2
normal
RESOLVED DUPLICATE of bug 1331761
a year ago
a year ago

People

(Reporter: ccomorasu, Assigned: dvander)

Tracking

Trunk
All
Windows
Points:
---

Firefox Tracking Flags

(firefox53 affected, firefox54 affected)

Details

(Whiteboard: [gfx-noted], crash signature)

[Affected versions]:
 Fx 53.0a3
 Fx 54.0a1

[Affected platforms]:
 Windows 10 x64
 Windows 8.1 x32
 Windows 7 x32

[Steps to reproduce]:
 1. Start Firefox.
 2. Check about:config if the pref "layers.gpu-process.enabled" is set to "true"
 3. Add the "layers.gpu-process.max_restarts" integer preference in about:config and set it to 0.
 4. Restart Firefox.
 5. Check the Windows task manager for 3 Firefox processes (some of them may be registered as a background process)
 5. Go to www.twitter.com and log in.
 6. Play a video and go to about:support and click "Terminate GPU Process" button.

[Expected result]:
 The browser glitches and resumes without any issues, no child process in the Task Manager.

[Actual result]:
 The browser crashes.

[Regression range]:
 No regression as this is a new feature

[Additional notes]:
 a. Screen cast with the issue: 
 b. This crash reproduces with multiple social media : facebook, twitter, reddit(with gif's as well)
 c. On Facebook if the playing video is from a share, the browser just glitches and resumes without any child process(expected behavior).
 d. Youtube works fine.
 e. Crash signatures:
 - c6b52039-0a4c-423d-9936-392252170301 (Facebook)
 - 3cb10538-9755-48aa-a78a-d126a2170301 (Facebook)
 - c2066056-0bb8-4d5c-a449-278882170301 (Twitter)
 - 112a1102-0439-473e-a7eb-233912170301 (Reddit)
Assignee: nobody → dvander
Has Regression Range: --- → no
Has STR: --- → yes
Will probably want to consider this for uplifts.
Priority: -- → P2
Whiteboard: [gfx-noted]
SurfaceDescriptor is the wrong type (TSurfaceDescriptorGPUVideo), so we end up trying to create GPU process specific thing when we don't have it anymore.
This crash would go away if we don't have the GPU video on by default?
I'm not sure what you mean by not having the GPU video on by default. Are you asking if the crash is reproducible without having the feature enabled (pref's off)? If that's the case, then there's no way for me to replicate the crash with the feature off (meaning, without the terminating the GPU process).

Also this crash started to occur on youtube as well.


Screen cast with a Facebook example: http://imgur.com/a/0Wkdv .
My bad, sorry; I meant if media.gpu-process-decoder is set to false in about:config.  Compositor process video decoding is on by default, and it requires compositor process enabled; however, it is a separate feature from the compositor process itself, and can be disabled separately.
Duplicate of this bug: 1344494
There are currently 22 reports of this crash in Beta. Given that ~1/3rd of Beta users have GPU Process available (based on Telemetry) I would expect this to have been reported a lot more if it was widespread. I would not consider this to blocker for release but would welcome an uplifted fix if one could be made available in time.
Crash Signature: [@ std::map<T>::operator[]]
Sorry that this fell off my radar - this should have been fixed by bug 1331761. (If not we can re-open)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1331761

Comment 8

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-esr52/rev/90f870bbec29
status-firefox-esr52: --- → fixed
(In reply to Ryan VanderMeulen [:RyanVM] from comment #8)
> https://hg.mozilla.org/releases/mozilla-esr52/rev/90f870bbec29

This was meant to be for bug 1343813. Misfire.
status-firefox-esr52: fixed → ---
You need to log in before you can comment on or make changes to this bug.