Closed Bug 1343914 Opened 3 years ago Closed 2 years ago

'Sync devices' field will be incorrectly displayed when switching between panels

Categories

(Firefox for iOS :: Home screen, defect, P3)

All
iOS
defect

Tracking

()

VERIFIED FIXED
Iteration:
1.30
Tracking Status
fxios 9.1 ---
fxios-v8.0 --- affected
fxios-v9.1 --- verified
fxios-v10.0 --- verified

People

(Reporter: SimonB, Assigned: jhugman)

References

Details

(Whiteboard: [nicetohave][VisualPolish][MobileCore])

Attachments

(1 file)

Build: c63f81b1
Device: iPhone 6
iOS: 9.3.5

Pre-requisite: 
- At least 2 devices synced with the same FxA

Steps to reproduce:
1. Go to History panel
2. Go to Bookmark panel 
3. Continue repeating steps 1) and 2) 

Actual results: 
- 'Sync devices' field will be incorrectly displayed.

See video: https://www.youtube.com/watch?v=JbFoCp-eRe8
Thats actually the "2 device(s) connected" text being animated in. 
When the panel first loads the text in the cell is just "Synced Devices" so it appears centered in the cell. When the subtitle text is added there is an animation which moves the title up in order to center both the title and subtitle correctly.

Because we query how many devices are connected after the panel loads theres an animation that occurs when the text is added.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1353480
I filed bug 1353480 because this looks really odd. I think we can do better.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
I agree with Aaron, from user point of view, although the functionality is not broken it looks weird, not very 'clean'
Priority: -- → P3
Whiteboard: [nicetohave]
Whiteboard: [nicetohave] → [nicetohave][VisualPolish]
Duplicate of this bug: 1397911
Whiteboard: [nicetohave][VisualPolish] → [nicetohave][VisualPolish][MobileCore]
Assignee: nobody → jhugman
Status: REOPENED → ASSIGNED
Iteration: --- → 1.30
Attachment #8909427 - Flags: review?(fpatel) → review+
Merged into master.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago2 years ago
Resolution: --- → FIXED
Whiteboard: [nicetohave][VisualPolish][MobileCore] → [nicetohave][VisualPolish][MobileCore][NeedsUplift]
Verifying as fix on master 90c97d6ec7.
Uplifted to v9.x
Whiteboard: [nicetohave][VisualPolish][MobileCore][NeedsUplift] → [nicetohave][VisualPolish][MobileCore]
Verifying as fix on 9.1(6241).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.