The default bug view has changed. See this FAQ.

Fix error in userprefs caused by logging into the sessions page

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
P3
normal
RESOLVED FIXED
24 days ago
19 days ago

People

(Reporter: dylan, Assigned: dylan)

Tracking

Production

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

24 days ago
Can't locate object method "cookie" via package "Bugzilla::Auth::Login::CGI" at /data/www/bugzilla.mozilla.org/userprefs.cgi line 790.
(Assignee)

Updated

24 days ago
Priority: -- → P1
(Assignee)

Comment 1

20 days ago
Created attachment 8844190 [details] [diff] [review]
1343936_1.patch

So if you login to the sessions page, your info getter object will be Bugzilla::Auth::Login::CGI which doesn't have a cookie method. 

This info is only used to show which session is current, so I think merely skipping that is fine. If the person refreshes the information will be correct.
Attachment #8844190 - Flags: review?(glob)
(Assignee)

Comment 2

20 days ago
This turned out to be unrelated to the other CI failures, but at the time it seemed like everything was failing. :-)
Priority: P1 → P3
Comment on attachment 8844190 [details] [diff] [review]
1343936_1.patch

Review of attachment 8844190 [details] [diff] [review]:
-----------------------------------------------------------------

r=glob
Attachment #8844190 - Flags: review?(glob) → review+
(Assignee)

Comment 4

19 days ago
To git@github.com:mozilla-bteam/bmo.git
   2636763..b72174d  master -> master
Status: NEW → RESOLVED
Last Resolved: 19 days ago
Resolution: --- → FIXED
(Assignee)

Updated

19 days ago
Summary: Strange error in userprefs.cgi → Fix error in userprefs caused by logging into the sessions page
You need to log in before you can comment on or make changes to this bug.