Closed Bug 1344446 Opened 3 years ago Closed 3 years ago

tab bar scroll buttons are too narrow for touchscreen use

Categories

(Firefox :: Theme, defect, P1)

51 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.2 - Aug 29
Tracking Status
firefox57 --- verified

People

(Reporter: billdillensrevenge, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Whiteboard: [photon-visual][p3])

Attachments

(2 files)

Attached image tabscrolbuttons.png
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

on a Surface Pro 4, if you have lots of tabs open, the arrow buttons that appear on either end of the tab bar that allow you to scroll horizontally are too narrow for touchscreen use. These buttons are pretty much the only part of the main Firefox GUI that are not touch friendly, please make them wider. Screenshot attached to show what I'm talking about.


(the "List all tabs" button also is not wide enough for touchscreen use but I don't think that is as important because that button isn't very useful)
Blocks: fx-touch
Component: Untriaged → Tabbed Browser
We should remember to fix this in bug 1363023.
Blocks: photon-touch
Depends on: 1363023
Whiteboard: [photon-visual][triage]
Flags: qe-verify+
Priority: -- → P2
QA Contact: brindusa.tot
Whiteboard: [photon-visual][triage] → [photon-visual]
Whiteboard: [photon-visual] → [photon-visual][p3]
Blocks: 1363023
No longer depends on: 1363023
Assignee: nobody → dao+bmo
Status: UNCONFIRMED → ASSIGNED
Component: Tabbed Browser → Theme
Ever confirmed: true
Priority: P2 → P1
Iteration: --- → 57.1 - Aug 15
Iteration: 57.1 - Aug 15 → 57.2 - Aug 29
Comment on attachment 8896615 [details]
Bug 1344446 - Use --toolbarbutton-inner-padding for the tab strip scroll buttons so that they honor UI density modes.

https://reviewboard.mozilla.org/r/167898/#review174506

This looks good thanks
Attachment #8896615 - Flags: review?(dharvey) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7c0790a19ee2
Use --toolbarbutton-inner-padding for the tab strip scroll buttons so that they honor UI density modes. r=daleharvey
https://hg.mozilla.org/mozilla-central/rev/7c0790a19ee2
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
QA Contact: brindusa.tot → ovidiu.boca
I verified this on Surface Pro 4 with Windows 10 with the latest Nightly 57.0a1(2017-08-22) and I can confirm the fix.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.