Closed Bug 1344490 Opened 3 years ago Closed 2 years ago

javascript window dialog loop is not prevent

Categories

(SeaMonkey :: General, defect)

SeaMonkey 2.46 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 578828

People

(Reporter: michael-remy, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: csectype-dos, Whiteboard: [sg:dos] check for dupes)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46
Build ID: 20161213183751

Steps to reproduce:

there are some "crapy" website with unsolicited javascript dialog bow in loop.
in mean in Loop, because, when you close/cancel the window, then it opens again and again and again....
Like this crapy one "be careful" : http://msfryoubhkol.site/index.html

sometime, seamonkey offer to block and not reopen the javascript alert box, but this kind of one   is not blocked.


Actual results:

there are some "crapy" website with unsolicited javascript dialog bow in loop.
in mean in Loop, because, when you close/cancel the window, then it opens again and again and again....
Like this crapy one "be careful" : http://msfryoubhkol.site/index.html

sometime, seamonkey offer to block and not reopen the javascript alert box, but this kind of one   is not blocked.


Expected results:

seamonkey should propose to block it once it will reopen 2 or 3 time in less than 5 seconds !
here another javascript trap loop where seamonkey is fallen there !
ESC won't work do cancel that **** script !
i hate such JS loop !

beware of this web page : only use to debug the trap
http://ramdamn06.club/FR1/index.html
Blocks: eviltraps
Group: core-security-release
Keywords: csectype-dos
Whiteboard: [sg:dos] check for dupes
As these sites no longer work, I don't know if we can diagnose here. There are many other duplicates to this bug in the eviltraps parent bug which could be followed.

Please let me know if you find another example site. Thanks!
Flags: needinfo?(michael-remy)
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578828
hi,

it's been a verry long time since i don't fall on such web trap (several months).
maybe we can close the bug too.
Flags: needinfo?(michael-remy)
You need to log in before you can comment on or make changes to this bug.