If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Source maps not loading in developer edition

RESOLVED DUPLICATE of bug 1360357

Status

()

Firefox
Developer Tools: Debugger
P2
normal
RESOLVED DUPLICATE of bug 1360357
7 months ago
4 months ago

People

(Reporter: Jithin Emmanuel, Unassigned)

Tracking

(Blocks: 1 bug, {testcase-wanted})

53 Branch
testcase-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20170125094131

Steps to reproduce:

My project uses browserify to bundle client side JS. Generated bundle has inline source maps.

OS-  Mac 10.12.3




Actual results:

When going to developer tools -> debugger I expect to see source maps, but this is not happening on Developer edition (53.0a2 latest).


Expected results:

Debugger should have shown source maps. This works correctly on latest stable FF release (51.0.1) and other major browsers.

Comment 1

7 months ago
Could you provide a testcase (like reduced example on jsfiddle or URL to public demo).
Component: Untriaged → Developer Tools: Debugger
Flags: needinfo?(jithin1987)
Keywords: testcase-wanted
(Reporter)

Comment 2

7 months ago
@Loic Here you go https://github.com/jithin1987/sourcemap-test

Open index.html. It loads a browserify generated js bundle.
Open developer tools -> debugger
Sourcemaps in that works on all browsers except FF Developer Edition.
Flags: needinfo?(jithin1987)
Blocks: 1339970

Updated

7 months ago
Priority: -- → P3

Updated

5 months ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: P3 → P2

Comment 3

4 months ago
I'm fixing inline sourcemaps in bug 1360357.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1360357
You need to log in before you can comment on or make changes to this bug.