Scrolling Distorts Flash Game "Pirate the Treasures Return"

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: JW_SoftvisionQA, Unassigned)

Tracking

53 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox54 affected, firefox55 affected)

Details

(URL)

(Reporter)

Description

a year ago
e10s is enabled
dom.ipc.plugins.asyncdrawing.enabled is enabled

STR: 
1. Navigate to http://ja.y8.com/games/pirate_the_treasures_return
2. Let flash content load then scroll

Expected:
Flash Content is not effected by the scroll

Actual:
Flash Content is distorted by the scroll

This is not reproducible when dom.ipc.plugins.asyncdrawing.enabled is disabled
Justin, what does the distorted Flash content look like? After I skip the ad and wait for the Flash game to load, I can scroll the page without any visual distortion. I'm using 64-bit Nightly 54 on Windows 10. Maybe this is a problem just with 32-bit Nightly?
Blocks: 1340934
Flags: needinfo?(jwilliams)
(Reporter)

Comment 2

a year ago
Here is a video of what I am seeing.

https://jwilliams-softvision.tinytake.com/sf/MTM5NTU0MF81MDQzMDg0

I am using 64 bit firefox on a Windows 7 64 bit machine.
Flags: needinfo?(jwilliams) → needinfo?(cpeterson)
Thanks! That does look bad. The video made the problem very clear.
status-firefox54: --- → affected
status-firefox55: --- → affected
Flags: needinfo?(cpeterson)
I cannot reproduce this with latest Nightly 55.0a1, 20170308030207 on Win 10 Surface Pro. 

STR's don't necessarily match what is being presented in comment #2 video.  In the video, scrolling is taking place during game "Preparing," not during game play.  I can't reproduce what has been reported in either case; game preparation phase nor in game play.
Duplicate of this bug: 1344941
(In reply to Justin [:JW_SoftvisionQA] from comment #2)
> Here is a video of what I am seeing.
> 
> https://jwilliams-softvision.tinytake.com/sf/MTM5NTU0MF81MDQzMDg0
> 
> I am using 64 bit firefox on a Windows 7 64 bit machine.

Thanks for this video. Seeing something like this is rather odd with windowless rendering. Regardless I don't think this blocks, it doesn't prevent game play. If the problem is more widespread (ads on popular news sites for example) we might. No reports like that have surfaced.
Are you seeing this in latest nightly?
Flags: needinfo?(jwilliams)
(Reporter)

Comment 8

a year ago
No I can not Jim. It looks like this issue has been fixed.
Flags: needinfo?(jwilliams) → needinfo?(jmathies)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(jmathies)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.