Cache the requestedLocales and availableLocales in LocaleService

RESOLVED DUPLICATE of bug 1348042

Status

()

Core
Internationalization
RESOLVED DUPLICATE of bug 1348042
9 months ago
7 months ago

People

(Reporter: gandalf, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
Initially, in bug 1344445 we're landing the code to retrieve user requested locales, but without caching.

This is intended to make it match 1-1 the current behavior we're going to replace with that call, but eventually we'll want to cache it in mRequestedLocales on LocaleService.
(Reporter)

Updated

9 months ago
Depends on: 1344445
(Reporter)

Updated

8 months ago
Blocks: 1346877
(Reporter)

Updated

8 months ago
Summary: Cache the requestedLocales in LocaleService → Cache the requestedLocales and availableLocales in LocaleService
(Reporter)

Comment 1

7 months ago
I'm caching requested as part of bug 1348042 and I'm not sure if we should cache available in the current form. Will handle that in bug 1358628.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1348042
You need to log in before you can comment on or make changes to this bug.