Closed Bug 1345920 Opened 3 years ago Closed 3 years ago

Hint the select iframe button when debugging add-on

Categories

(WebExtensions :: Developer Tools, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1302702

People

(Reporter: yfdyh000, Unassigned)

References

Details

(Keywords: ux-discovery, Whiteboard: triaged)

Attachments

(1 file)

STR:
1. Load the https://github.com/andymckay/sidebar-tabs on about:debugging#addons in Nightly 54, then click the Debug button.
2. Allow the debugging. You will see a window with "Your addon does not have any document opened yet.".


Actual result:
It misled me that this add-on can not be debugging with devtools.


Expected result:
Hint/Prompt to select a iframe, even automatically switch to the available sidebar / background document.
Attached image Screenshot
Luca, is this a bug you'd like to move to WebExtensions: Developer Tools ?
Flags: needinfo?(lgreco)
Thanks Julian!

yes, it is definitely a bug specific to the WebExtensions RDP actor.

The behavior requested in Comment 0 is part of the changes that I'm already working on as part of Bug 1302702 (in the new version of the webextension RDP actor that I'm working on, the toolbox should be switched automatically to a newly created extension page, e.g. a sidebar or a popup, if the current selected frame is the fallback window, the one that contains the "Your addon does not have any document opened yet.").

I'm going to move this issue into the "Toolkit/WebExtensions: Developer Tools" component and add Bug 1302702 as its dependency.
Component: Developer Tools: about:debugging → WebExtensions: Developer Tools
Depends on: 1302702
Flags: needinfo?(lgreco)
Product: Firefox → Toolkit
luca to dupe or close
Flags: needinfo?(lgreco)
Whiteboard: triaged
As briefly described in Comment 3, with Bug 1302702 the addon debugging toolbox is going to automatically switch from the fallback window to a real extension window (e.g. a popup window) as soon as it as been detected.

Nevertheless, I agree that it would be nicer to make the user aware when changes to the frame list or to the current selected frame happens.

And so, after brefly discussing this with :jdescottes over IRC, we agreed that it would make sense to file separate bugs for the generic enhancement required to the toolbox to make these kind of changes more visible to the users also for the other supported toolbox targets (like tabs and processes).

I've filed the following two bugzilla issues:

- Bug 1363133 - Highlight the frame selector button on frame list updates, which is related to highlight the button on any changes received by the toolbox on the frame list

- Bug 1363134 - Warn the user when the current selected frame has been changed without direct user interaction, which is related to warning the user when the current selected frame is changed without user interaction

I'm also duping this to Bug 1302702, as the bugzilla issue that provides the initial part of the behavior requested in Comment 0 ('automatically switch to the available sidebar / background document').
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
No longer depends on: 1302702
Flags: needinfo?(lgreco)
Resolution: --- → DUPLICATE
See Also: → 1363133, 1363134
Duplicate of bug: 1302702
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.