File save/open dialog crashes Firefox /Linux RHEL 7/CentOS 7 64 (libglib-2.0.so.0.4600.2@0x50643)

RESOLVED WONTFIX

Status

()

P3
critical
RESOLVED WONTFIX
2 years ago
2 months ago

People

(Reporter: aros, Unassigned)

Tracking

({crash})

52 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tpi:+, crash signature)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170302120751

Steps to reproduce:

Environment: CentOS 7.0 64 with all updates and binary NVIDIA drivers (378.13)

1) Go to https://ftp.mozilla.org/pub/firefox/releases/52.0/linux-x86_64-EME-free/en-US/
2) Left click firefox-52.0.tar.bz2
3) Choose a location to download


Actual results:

Crash/Segfault

bp-61edc232-3ab2-41f8-ad7b-2e0da2170309
bp-11f93b58-4ef2-4247-b576-cd5cf2170309



Expected results:

Additional info:

* zero add-ons installed
* zero plugins enabled
* pretty much default settings except runs in private mode by default

Updated

2 years ago
Severity: normal → critical
Crash Signature: libglib-2.0.so.0.4600.2@0x50643
Keywords: crash
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

2 years ago
Crash Signature: libglib-2.0.so.0.4600.2@0x50643 → [@ libglib-2.0.so.0.4600.2@0x50643 ]
(Reporter)

Comment 1

2 years ago
In fact simple Ctrl + O crashes the browser immediately.

Something is wrong with GTK save/open file dialog.
(Reporter)

Updated

2 years ago
Summary: Firefox 52/Linux crashes while trying to download any file (libglib-2.0.so.0.4600.2@0x50643) → File save/open dialog crashes Firefox 52/Linux CentOS 7 64 (libglib-2.0.so.0.4600.2@0x50643)
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

I have tested your issue on latest Firefox release v52 and latest Nightly (Build ID: 20170313110417) on Ubuntu 14.04 x64 and could not reproduce it. I have followed the steps from comment 0 and tried also with other webpages like www.dropbox.com or www.drive.google.com, but all files are successfully saved. Unfortunately I do not have a CentOS 7.0 64 machine and I am unable to test exactly the scenario provided.

Can you please retest this using latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/AR5o9d). 

I will assign a possible related component. Maybe someone with a similar machine could provide some feedback for this issue.
Component: Untriaged → Widget: Gtk
Flags: needinfo?(t.artem)
Product: Firefox → Core
(Reporter)

Comment 3

2 years ago
Firefox nightly with a completely new profile (~/.mozilla had been removed prior to starting Firefox):

Crash ID: bp-3cc19140-e7cc-46f5-a862-319962170314
Flags: needinfo?(t.artem)
If the distribution has not applied a patch for https://bugzilla.gnome.org/show_bug.cgi?id=762994
then this is likely a duplicate of bug 1244305.
Depends on: 1244305
(Reporter)

Comment 5

2 years ago
RHEL might never fix this bug so here's a workaround:

ui.allow_platform_file_picker = false
(Reporter)

Comment 6

2 years ago
I've filed a bug report against RHEL 7.3: https://bugzilla.redhat.com/show_bug.cgi?id=1432339

Updated

2 years ago
Priority: -- → P3
Whiteboard: tpi:+
See Also: → bug 1385693
Closing because no crash reported since 12 weeks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
(Reporter)

Comment 8

5 months ago
ORLY?

https://crash-stats.mozilla.com/report/index/fabaeace-6a5d-425e-aa96-4f3820181001
https://crash-stats.mozilla.com/report/index/d9161fa0-bcb7-4260-84ef-5ea580181001

Yes, it surely looks like zero CentOS 7/RHEL 7 users aside from me use the official Firefox distribution and perhaps all others use RPMs but that that doesn't solve the bug.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Updated

5 months ago
Summary: File save/open dialog crashes Firefox 52/Linux CentOS 7 64 (libglib-2.0.so.0.4600.2@0x50643) → File save/open dialog crashes Firefox /Linux RHEL 7/CentOS 7 64 (libglib-2.0.so.0.4600.2@0x50643)
:Artem, the two reports you mentioned have signature "libglib-2.0.so.0.5400.2@0x503f1" which is different from what we've in the signature field.
If it's the same issue, please update the signature field to add this one.
Flags: needinfo?(aros)
(Reporter)

Comment 10

5 months ago
(In reply to Calixte Denizet (:calixte) from comment #9)
> :Artem, the two reports you mentioned have signature
> "libglib-2.0.so.0.5400.2@0x503f1" which is different from what we've in the
> signature field.
> If it's the same issue, please update the signature field to add this one.

Actually I'm not sure if it's the same issue or not, but the last two reported (must be three now - I accidentally tried to upload a file a few seconds ago) crashes contain the valid signature which is what this bug report is about. Please adjust the value yourself because I'm not sure how to do that properly.
Flags: needinfo?(aros)
Closing because no crashes reported for 12 weeks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.