Closed Bug 1345967 Opened 5 years ago Closed 5 years ago

Stuck about:firefox stuck at 'Looking for updates…' even after notification that new update is available

Categories

(Firefox for Android Graveyard :: General, defect)

Unspecified
Android
defect
Not set
major

Tracking

(firefox52 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 verified)

VERIFIED FIXED
Firefox 55
Tracking Status
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- verified

People

(Reporter: aryx, Assigned: jchen)

References

Details

(Keywords: regression)

Attachments

(1 file)

Firefox for Android 55.0a1 20170308 and 20170309 on Sony Xperia Z3C (Android 6.0.1)

With Firefox set to never automatically download updates, opening about:firefox and checking for updates lets the button get stuck at 'Looking for updates…' even after a notification that a new update is available got added in the notification tray.
I am seeing the same symptoms trying to update from 20170310.  No idea if this was triggered by a change in the client or a failure in the update infrastructure, but even if it is the latter, it shoudl never result in just hanging forever at checking for updates.  There is definitely and update client issue here.
Severity: normal → major
OS: Unspecified → Android
Version: unspecified → Trunk
Actually this is probably even worse than I thought.  Batteries draining at an alarming rate.  I suspect the automatic check for updates is also hanging resulting in excessive battery drain.
This is a regression from bug 1337467. The debugger reveals that |listener| at https://hg.mozilla.org/mozilla-central/rev/8098ab33c1b6#l33.36 gets optimized away, so that statement fails and |showUpdateMessage| doesn't get called. Please also fix the indentation for the block.
Blocks: 1337467
Flags: needinfo?(nchen)
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
Use the global EventDispatcher for signaling update results. The event
listener in about.js must be unregistered after every event to prevent
memory leaks, so expectUpdateResult() is added and called whenever we
are expecting update results.
Attachment #8846924 - Flags: review?(s.kaspari)
Attachment #8846924 - Flags: review?(s.kaspari) → review+
Duplicate of this bug: 1347612
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3cf42045e783
Use global EventDispatcher for update messaging; r=sebastian
What are the chances of getting this merged before tomorrows mozilla-central nightly?  This has really been going on long enough, just my opinion, I could be wrong!
https://hg.mozilla.org/mozilla-central/rev/3cf42045e783
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Verified as fixed in build 55.0a1 2017-03-20 to 2017-03-21;
Device: HTC 10 (Android 6.0.1).
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.