Some Speedometer tests spend a lot of time in IonBuilder

RESOLVED FIXED in Firefox 55

Status

()

enhancement
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jandem, Assigned: jandem)

Tracking

(Blocks 1 bug)

unspecified
mozilla55
Points:
---

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
The Ember part of Speedometer has some small-ish functions that we Ion-compile more eagerly but these functions then inline larger functions so we're stuck in IonBuilder for a while. Increasing our small-function limit seems to be a nice win and doesn't regress anything so we should try that first.
(Assignee)

Comment 1

2 years ago
Posted patch PatchSplinter Review
This patch uses the normal warmup threshold for small functions too. I think it's worth trying to see how it affects AWFY. If it doesn't regress anything we could later simplify the code a bit, if it does regress something we can back out or try something else.
Assignee: nobody → jdemooij
Status: NEW → ASSIGNED
Attachment #8845893 - Flags: review?(hv1989)
Attachment #8845893 - Flags: review?(hv1989) → review+

Comment 2

2 years ago
Pushed by jandemooij@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/230e0c324669
Change Ion warmup threshold for small functions to be the same as the one for other functions. r=h4writer

Comment 3

2 years ago
Pushed by jandemooij@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4e048aaa479f
followup - Add array-isArray-proxy-recursion.js to cgc-jstests-slow.txt. r=red
(Assignee)

Comment 4

2 years ago
This regressed SunSpider by a few ms, but it improved Speedometer by ~4 points (7% or so) and the react-shell test also got 5-9% faster.

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/230e0c324669
https://hg.mozilla.org/mozilla-central/rev/4e048aaa479f
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Seems the link between perfherder and awfy is cut. Fixing now to get those results. But I think this is an acceptable trade-off. I did try optimizations levels to reinstate this, but I keep getting regressions on sunspider, since we compile more. (IonBuilder).

Updated

2 years ago
Duplicate of this bug: 1330249
You need to log in before you can comment on or make changes to this bug.