Firefox instacrashing startup in [@ DWriteFontTypeface::onFilterRec ]

VERIFIED FIXED in Firefox 55

Status

()

Core
Graphics: Text
--
blocker
VERIFIED FIXED
a year ago
3 months ago

People

(Reporter: Virtual, Assigned: emk)

Tracking

(8 keywords)

55 Branch
mozilla55
All
Windows
crash, crashreportid, dogfood, nightly-community, regression, topcrash, topcrash+, topcrash-win
Points:
---

Firefox Tracking Flags

(firefox-esr45 unaffected, firefox52 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55+ verified)

Details

(Whiteboard: [fixed by updated patch from bug #1345222], crash signature)

"Speedy" Regression window (mozilla-central)
Good:
https://ftp.mozilla.org/pub/firefox/nightly/2017/03/2017-03-09-03-02-16-mozilla-central/

Bad:
https://ftp.mozilla.org/pub/firefox/nightly/2017/03/2017-03-10-03-02-05-mozilla-central/

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c40ca7a1bdd93632c6bdc5e23bd33d984d508b19&tochange=9b0f116a58d6adb6934f50bcf220cc3ca4343d60


Probably caused by:
c8bfaf1927b6	Daniel Holbert — Bug 1291483 part 2: Use UniquePtr/MakeUnique more thoroughly in chain-of-custody for gfxFont::mVerticalMetrics. r=jfkthame
5a0c4791eef5	Daniel Holbert — Bug 1291483 part 1: Use 'MakeUnique' instead of 'new' to allocate gfxFont::mGlyphChangeObservers. r=jfkthame
Blocks: 1291483
Severity: normal → critical
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(dholbert)
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Summary: Mozilla Firefox Nightly 55.0a1 (2017-03-10) crashing in [@ DWriteFontTypeface::onFilterRec ] → Firefox instacrashing startup in [@ DWriteFontTypeface::onFilterRec ]
Severity: critical → blocker
Keywords: dogfood, topcrash, topcrash-win
OS: Windows 7 → Windows
Hardware: x86_64 → All
Version: 54 Branch → 55 Branch
this got backed out in https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=528e9dbbb882db0b32792d44b5be9cc539afa1a8 and retriggering the nightlys now.


Marking this one as "fixed" and comment in Bug 1291483
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(jfkthame)
Flags: needinfo?(dholbert)
Flags: needinfo?(cbook)
Resolution: --- → FIXED
tracking-firefox55: ? → +
Adding the mac signature to this bug so it gets picked up in crash stats.
Crash Signature: [@ DWriteFontTypeface::onFilterRec ] → [@ DWriteFontTypeface::onFilterRec] [@ gfxTextRun::BreakAndMeasureText]
Comment hidden (obsolete)
(In reply to Marcia Knous [:marcia - use ni] from comment #4)
> Adding the mac signature to this bug so it gets picked up in crash stats.

Actually, even though the same build ID it is a different bug, so removing.
Crash Signature: [@ DWriteFontTypeface::onFilterRec] [@ gfxTextRun::BreakAndMeasureText] → [@ DWriteFontTypeface::onFilterRec]
How sure are we that the backout backed out the right thing and fixed this?

Last night aja was hitting this crash locally (using autoland treeherder builds), and he initially suspected the same cause (my patches in Bug 1291483), but he was later able to reproduce with a build from *just before* that landed, which (unless he made a mistake) means the backout that we've done here won't help!

He ended up isolating  bug 1345222 (which also landed last night, also font-related) as the cause -- see bug 1345222 comment 28.

Unless we're absolutely sure that the backout we've already done fixes it, we should probably backout bug 1345222 as well and retrigger nightlies.
I've pushed a backout of bug 1345222 to m-c. Retriggering nightlies again as well.
Actually, there's no way bug 1345222 is causing the Linux/OSX crashes as it touched Windows-only code. Bug 1056516 looks like a way more likely culprit for those. I have no clue if it's *also* responsible for the Windows crashes, so I'm going to leave the rest backed out to play it safe.

https://hg.mozilla.org/mozilla-central/rev/a8d497b09753c91783b68c5805c64f34a2f39629

Hopefully *these* nightlies are in better shape across all platforms!

Comment 11

a year ago
I just downloaded latest nightly - still instacrashing. How long should I wait?
More than 30 minutes. We'll un-freeze nightly updates when there's a build worth trying.
(In reply to Daniel Holbert [:dholbert] from comment #8)
> aja [...] ended up isolating  bug 1345222 (which also landed last night, also
> font-related) as the cause -- see bug 1345222 comment 28.

--> Updating "blocks" field to reflect this.

(aja triple-checked this using treeherder builds, and verified that local crashes have the same signature as this bug here)
Blocks: 1345222
No longer blocks: 1291483

Updated

a year ago
Duplicate of this bug: 1346306
I also retested now it on inbound builds to confirm this
and the real culprit is indeed bug #1345222.

@ Daniel Holbert [:dholbert], Carsten Book [:Tomcat], Ryan VanderMeulen [:RyanVM] - I'm very sorry for the confusion.
Status: RESOLVED → VERIFIED
status-firefox55: affected → verified
All of the Nightly re-spins have finished (finally) and updates are un-frozen.
Target Milestone: --- → mozilla55

Comment 17

a year ago
Not crashing here anymore (Win7)
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me) from comment #15)
> I also retested now it on inbound builds to confirm this
> and the real culprit is indeed bug #1345222.

(Thanks for double-checking, and for filing this bug & getting traction in the first place!)

(In reply to Codacoder from comment #17)
> Not crashing here anymore (Win7)

Woohoo, thanks for verifying. I'm glad we got this sorted out & fixed.
Assignee: nobody → VYV03354
Whiteboard: [fixed by updated patch from bug #1345222]
You need to log in before you can comment on or make changes to this bug.