Permafailing android-findbugs | Findbugs found issues in the project. See the report at: https://queue.taskcluster.net/v1/task/I2f2I-pnTpyp9_hB4ySDug/runs/0/artifacts/public/android/findbugs/findbugs-report.html

RESOLVED DUPLICATE of bug 1346390

Status

()

Firefox for Android
Android Sync
RESOLVED DUPLICATE of bug 1346390
a year ago
6 months ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
treeherder
Filed by: wkocher [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=82892491&repo=autoland

https://queue.taskcluster.net/v1/task/I2f2I-pnTpyp9_hB4ySDug/runs/0/artifacts/public/logs/live_backing.log

The failure is apparently:
Bx 	Boxing/unboxing to parse a primitive org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.getDeviceRegistrationTimestamp()

 	

Bug type DM_BOXED_PRIMITIVE_FOR_PARSING (click for details)
In class org.mozilla.gecko.fxa.authenticator.AndroidFxAccount
In method org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.getDeviceRegistrationTimestamp()
Called method Long.longValue()
Should call Long.parseLong(String) instead
At AndroidFxAccount.java:[line 844]
Ah, didn't see this one.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1346390

Comment 2

a year ago
13 failures in 790 pushes (0.016 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 8
* try: 3
* oak: 2

Platform breakdown:
* android-4-0-armv7-api15: 13

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1346362&startday=2017-03-06&endday=2017-03-12&tree=all
Comment hidden (admin)

Updated

6 months ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.