stylo: Intermittent leakcheck | default process: 16 bytes leaked (nsStringBuffer)

RESOLVED FIXED in Firefox 55

Status

()

Core
CSS Parsing and Computation
P1
normal
RESOLVED FIXED
2 months ago
a month ago

People

(Reporter: Treeherder Bug Filer, Assigned: xidorn)

Tracking

({intermittent-failure, mlk})

unspecified
mozilla55
intermittent-failure, mlk
Points:
---

Firefox Tracking Flags

(firefox52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 fixed, firefox-esr52 unaffected)

Details

(Whiteboard: [stockwell disabled])

(Reporter)

Description

2 months ago
treeherder
Filed by: cbook [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=83346271&repo=autoland

https://queue.taskcluster.net/v1/task/ZXXFVG2USGeyOT_fZlp51g/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/ZXXFVG2USGeyOT_fZlp51g/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

Updated

2 months ago
Component: General → General
Product: Chat Core → Core
Version: trunk → unspecified

Updated

2 months ago
Keywords: mlk
bobby: this seems a new intermittent leak in stylo tests, could you take a look, thanks!
Flags: needinfo?(bobbyholley)
Looks like this started with the landing of bug 1315601. Seems to be happening about 80% of the time so we should jump on this quickly.

Over to xidorn.
Assignee: nobody → xidorn+moz
Blocks: 1315601
Flags: needinfo?(bobbyholley) → needinfo?(xidorn+moz)
Priority: -- → P1
Summary: Intermittent leakcheck | default process: 16 bytes leaked (nsStringBuffer) → stylo: Intermittent leakcheck | default process: 16 bytes leaked (nsStringBuffer)
Component: General → CSS Parsing and Computation
The earliest push with this leak is from bug 1341690: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=8949490f91a7c560485e1d5a350718924b4cb9a2&selectedJob=83324109

The URL change seems to be a more sensible candidate since bug 1315601 doesn't have much work on string stuff.

I assume heycam would know more.
Flags: needinfo?(xidorn+moz) → needinfo?(cam)
FWIW, according to my local run last night, it seems to me the leak happens inside one of layout/reftests/{dom,generated-content}. I saw them intermittently, but failed to further locate where the issue is.
Also, this bug can be from bug 1296477, which makes more sense with the generated-content bits. manish?
Flags: needinfo?(manishearth)
Yeah, that is possible as well, since the task crashes before bug 1341690's push.
No longer blocks: 1315601

Comment 7

2 months ago
59 failures in 142 pushes (0.415 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 51
* mozilla-central: 5
* mozilla-inbound: 3

Platform breakdown:
* linux64-stylo: 58
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1346734&startday=2017-03-13&endday=2017-03-13&tree=all
It is layout/reftests/dom/xbl-children-3.xhtml leaking.

I'm going to disable this test in this bug, and file a new bug investigating the reason.
Flags: needinfo?(manishearth)
Flags: needinfo?(cam)

Comment 9

2 months ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ce635599e0c1
Disable the leaking reftest.
Filed bug 1347065.
thanks for disabling this test
Whiteboard: [stockwell disabled]

Comment 12

2 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ce635599e0c1
Status: NEW → RESOLVED
Last Resolved: 2 months ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
status-firefox52: --- → unaffected
status-firefox53: --- → unaffected
status-firefox54: --- → unaffected
status-firefox-esr52: --- → unaffected

Comment 13

2 months ago
33 failures in 149 pushes (0.221 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* mozilla-inbound: 16
* autoland: 16
* try: 1

Platform breakdown:
* linux64-stylo: 33

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1346734&startday=2017-03-14&endday=2017-03-14&tree=all

Comment 14

a month ago
98 failures in 777 pushes (0.126 failures/push) were associated with this bug in the last 7 days. 

This is the #13 most frequent failure this week. 

** This failure happened more than 75 times this week! Resolving this bug is a very high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 1 week, the affected test(s) may be disabled. **  

Repository breakdown:
* autoland: 68
* mozilla-inbound: 23
* mozilla-central: 6
* try: 1

Platform breakdown:
* linux64-stylo: 97
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1346734&startday=2017-03-13&endday=2017-03-19&tree=all
You need to log in before you can comment on or make changes to this bug.