MailNews segfaults during "download and sync"

VERIFIED DUPLICATE of bug 134070

Status

SeaMonkey
MailNews: Backend
--
critical
VERIFIED DUPLICATE of bug 134070
16 years ago
13 years ago

People

(Reporter: basic, Assigned: Bienvenu)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
UA: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020329

I often do a File->Offline->"Download and Sync Now..." when starting MailNews
and then start reading the messages even before all of them are downloaded.
Recently I've been seeing crashes (not sure if they were there before). Here are
some talkback ids:

TB4679591E
TB4679667Y
TB4703535X
TB4703668W

Not sure what is causing this. Might even be a dup.
(Reporter)

Updated

16 years ago
Severity: normal → critical
Keywords: crash

Comment 1

16 years ago
Basic,
How many mesgs are you downloading? Are you checking the work offline
checkbox when download completes in download/sync now window?
I assume you were using imap mail account also.

Using commercial trunk 2002040108 on linux 2.2 this works for me
I tried downloading inbox of 100 mesgs (no work offline checkbox checked)
and I was able to read mesgs while they were downloading.

Tried another folder of 800+ mesgs (this time w/work offline checkbox
checked) and I was able to read mesgs while downloaded. I even
tried opening some of downloaded mesgs in a new window and it worked.

No crash for me.

Basic's stack trace:
_pl_GetEventCount() 
PL_ProcessPendingEvents() 
nsEventQueueImpl::ProcessPendingEvents() 
event_processor_callback() 
our_gdk_io_invoke() 
libglib-1.2.so.0 + 0xf2f0 (0x4038b2f0) 
libglib-1.2.so.0 + 0x10b86 (0x4038cb86) 
libglib-1.2.so.0 + 0x111b3 (0x4038d1b3) 
libglib-1.2.so.0 + 0x1137c (0x4038d37c) 
libgtk-1.2.so.0 + 0x92d2c (0x402a5d2c) 
nsAppShell::Run() 
nsAppShellService::Run() 
main1() 
main() 
libc.so.6 + 0x1cc6f (0x404d6c6f) 
(Assignee)

Comment 2

16 years ago
here's the stack trace:

_pl_GetEventCount()
PL_ProcessPendingEvents()
nsEventQueueImpl::ProcessPendingEvents()
event_processor_callback()
our_gdk_io_invoke()
libglib-1.2.so.0 + 0xf2f0 (0x4038b2f0)
libglib-1.2.so.0 + 0x10b86 (0x4038cb86)
libglib-1.2.so.0 + 0x111b3 (0x4038d1b3)
libglib-1.2.so.0 + 0x1137c (0x4038d37c)
libgtk-1.2.so.0 + 0x92d2c (0x402a5d2c)
nsAppShell::Run()
nsAppShellService::Run()

I don't know if there have been any recent linux event queue changes... I'll
seach bugzilla for the same stack trace.

(Reporter)

Comment 3

16 years ago
sorry for not being clearer, I was reading newsgroup messages and downloading
news messages from news.mozilla.org
(Assignee)

Comment 4

16 years ago
what skin are you using? There are a couple bugs with the same stack trace: bug
132597 and bug 134070 - one of them has a patch in it. Also, are you running on
a single cpu machine or dual-processor?
(Reporter)

Comment 5

16 years ago
> How many mesgs are you downloading?
Sometimes alot and sometimes less, not sure if that has anything to do with it.
I can't always repro this bug, but I see it as often as once a day (sometimes more).

> Are you checking the work offline checkbox when download completes in 
> download/sync now window?
no "work offline"

> what skin are you using?
classic

> There are a couple bugs with the same stack trace: bug 132597 and bug 134070 -
one of them has a patch in it.
hmm, guess they are related. I do use pop mail and had a "crash logging into pop
mail server" problem (sorry didn't get a talkback build back then) about a week
ago when I created a new pop mail account (seem to have disappeared now).

> Also, are you running on a single cpu machine or dual-processor?
single processor

Comment 6

16 years ago
Trying it with Newsgroups (no workoffline checkbox checked) in
the classic theme, I could not crash. Worked for me.

But I did see the exact same stack crash doing 2 different things:
 1) I clicked on secnews group. It asked me to download 500 headers
    I said yes. it asked me for my password, I clicked cancel and
    it crashed. TB4705372K
 2) I just subscribed to couple of mozilla newsgroups. I clicked on
    a newsgroup, got prompt to download 500, I said ok. I then clicked
    on another newsgroup, got the prompt to download 500, I said ok
    to 2nd newsgroup and it crashed TB4706073W

Both cases had same exact stack trace.

Don't think this is a offline bug..
(Assignee)

Comment 7

16 years ago
For fun, you might try switching to the modern skin and see if the problem goes
away. 
(Reporter)

Comment 8

16 years ago
I'm wasn't sure where to file this so I file it in "offline". I'll try modern
(Reporter)

Comment 9

16 years ago
crash with modern skin TB4708619M

one way I have found that will cause the crash (almost reliably) is to press the
spacebar again and again and again (to cause page down and go to the next new
message) while mailnews is doing the "download and sync" for the newsgroups.
(Assignee)

Comment 10

16 years ago
that crash looks like the pop3 prompt one, and also involves a dialog getting
popped up (and, I guess, events getting processed on the wrong thread, or
something). The dialog is the "do you want to advance to the next folder" one.
(Reporter)

Comment 11

16 years ago
my guess is this is a likely dup of bug 134070 then

Comment 12

16 years ago
Ok for now i'll mark as dupe of 134070.
Basic if you still see this bug after that other bug
is fixed, please reopen.

*** This bug has been marked as a duplicate of 134070 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
it's that bug, for sure.  Cropping up all over the place.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.