Closed Bug 1347035 Opened 3 years ago Closed 3 years ago

Remove PBrowser::Msg_GetMaxTouchPoints

Categories

(Core :: DOM: Core & HTML, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: ehsan, Assigned: ehsan)

References

(Blocks 1 open bug)

Details

(Whiteboard: [qf:p1])

Attachments

(1 file)

The only widget layers that currently implement this are Android and Windows and they both return a constant number!  We shouldn't be doing a sync IPC for this.
I wrote a patch for this one and it's pretty straightforward, but this touches on the code where we create a TabChild in the child process and send a PBrowser constructor to the parent for it which I have touched in bug 1343728.  In that code we need to get the max touch points from the widget in the parent process and I'm planning to piggy back on the code I have in bug 1343728 for the work I need to do here, so I will finish my work there before resuming the work here.
Depends on: 1343728
Whiteboard: [qf:p1]
Maybe Stone can take this since you're a bit busy, Ehsan.
Flags: needinfo?(sshih)
Priority: -- → P2
I'd love to take this. I guess I should wait for bug 1343728 and base on the patches of it, right?
Flags: needinfo?(sshih)
(In reply to Ming-Chou Shih [:stone] from comment #3)
> I'd love to take this. I guess I should wait for bug 1343728 and base on the
> patches of it, right?
Flags: needinfo?(ehsan)
Blocks: 1362068
(In reply to Ming-Chou Shih [:stone] from comment #3)
> I'd love to take this. I guess I should wait for bug 1343728 and base on the
> patches of it, right?

Sorry for the long delay in responding Stone.  I already have a semi-complete patch for this, but it does touch the same code as bug 1343728 so I have decided to finish that before resuming it.  Finishing this is pretty easy so as soon as I finish working on bug 1343728 I will get back to this one, I'm not too worried about it.  I just don't want anything to bitrot my patches there.  :-)
Flags: needinfo?(ehsan)
Comment on attachment 8870471 [details] [diff] [review]
Store the maximum touch points for each tab child on the object instead of querying it synchronously from the parent actor when neeeded

+               uint32_t macTouchPoints);
max

Please modify GetMaxTouchPoints to not do extra caching, it could always just
null check tabchild and if not null get the value from it and otherwise 0.
Attachment #8870471 - Flags: review?(bugs) → review+
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/67b98babb3b2
Store the maximum touch points for each tab child on the object instead of querying it synchronously from the parent actor when neeeded; r=smaug ipc-r=kanru
https://hg.mozilla.org/mozilla-central/rev/67b98babb3b2
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Component: DOM → DOM: Core & HTML
Regressions: 1539497
You need to log in before you can comment on or make changes to this bug.