Web Apps (and custom tabs) flash previously opened content

VERIFIED FIXED

Status

()

Firefox for Android
General
P2
normal
VERIFIED FIXED
a year ago
9 months ago

People

(Reporter: daleharvey, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox58 verified)

Details

(Reporter)

Description

a year ago
Install and open pokedex.org, if I use the browser then switch to the pokedex activity, the content of the last opened tab in the browser flashes inside the pokedex.org activity, before reverting to its own content

This may possibly be a dupe bug for custom tabs, mostly keeping track
(Reporter)

Updated

a year ago
Blocks: 1285858
That's a side effect of sharing the same GeckoView and browser window - we have some logic in GeckoApp instead that keeps track of the last selected tab in that particular GeckoApp instance and then switches the selected tab if necessary (https://dxr.mozilla.org/mozilla-central/rev/9577ddeaafd85554c2a855f385a87472a089d5c0/mobile/android/base/java/org/mozilla/gecko/GeckoApp.java#2239). Maybe based on that we can figure something out to stop painting until ready for the case when we're switching between different kinds of GeckoApp.
Priority: -- → P1
ni myself to find resource for this.
Flags: needinfo?(whuang)
I think the corresponding issue in Custom Tabs is Bug 1353732
clear NI as we'll review all the P1 dependencies around stand alone mode tomorrow.
Flags: needinfo?(whuang)
We haven't found available bandwidth to take this one for the current sprint.
We need at least a workaround to improve this symptom before we have GeckoView in place for standalone mode.
With the new dynamic toolbar, we now get not only the previous content momentarily flashing up, but occasionally (presumably if the toolbar was previously shown) a red stripe at the top of the screen as well.
(Reporter)

Comment 7

a year ago
Ah I wondered what that red flash was
For the (new) case of switching activities by selecting a different tab type (e.g. opening a link in a new tab from a custom tab/web app), I think bug 1359531 might help because the event order there will be slightly rearranged:

Previously, we'd start the activity switch and then switch tabs in Gecko only after the new activity has started up (and is possibly already showing the previous tab). With bug 1359531, we'll start selecting the tab first and then simultaneously switch activities, which empirically seems to help here.

This won't help in the case where the user is switching activities, though...
Bug 1364044 is a more serious issue, though not necessarily relevant to this.
In the triage we degraded this one to P2, and let's revisit.
Priority: P1 → P2
Duplicate of this bug: 1369117
Custom tabs have the same underlying issue.
Summary: Web Apps flash previously opened content → Web Apps (and custom tabs) flash previously opened content
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Comment 13

9 months ago
No longer occurs in Nightly 58. Fixed.
Status: RESOLVED → VERIFIED
status-firefox58: --- → verified
You need to log in before you can comment on or make changes to this bug.