Too slow (10-15 seconds) marking as not spam (not junk) and deleting messages

RESOLVED INVALID

Status

Thunderbird
Untriaged
--
minor
RESOLVED INVALID
7 months ago
4 months ago

People

(Reporter: Sergio, Unassigned)

Tracking

({perf})

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2017-07-01])

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170303012224

Steps to reproduce:

Marked a message as "not spam", this problem also occurs when deleting multiple messages (takes an eternity to finish and refresh the window). Version 45.8 - Linux - Ubuntu


Actual results:

message takes about 10 incredible seconds to be moved from the current folder to my inbox folder.


Expected results:

when you mark a message as not spam, the automatic message moving should take less then a second or be immediate to user.
(Reporter)

Comment 1

7 months ago
More detail: I have multiple accounts (about 7) and I keep messages from last 2 years. I think quantity of messages should not interfere (so much) in an operation of marking as not spam, because I am marking one unique message, not doing a search.

Comment 2

7 months ago
This has nothing to do with search, unless you are using a filter on the Spam folder.

> I keep messages from last 2 years
Which folder are you talking about - spam folder? inbox?
And how many messages are in the folder?

> message takes about 10 incredible seconds to be moved from the current folder to my inbox folder.
again, what is the current folder?

(please make you comments as precise as possible)
Flags: needinfo?(dosergio)
(Reporter)

Comment 3

7 months ago
question 1: read again with care: I said I am marking a message as not spam, NOT doing a search. I never said it was a search.

question 2: I have about 400 messages in total, I use also multiple filters for incoming messages. I keep my email files in a different partition. Using symbolic link as Mail folder, pointing to where it is, in the other partition. Does it affect?

question 3: If I am marking a message as not spam, we suppose we are talking about Trash folder. Some filters I made take messages to Trash. But sometimes I decide I want to keep some of them. In this moment I mark as not spam, the current folder is Trash, and it takes about 15 seconds to be moved from Trash to my Inbox folder.

It has nothing to do with this bug, but there is something even more annoying: links can not open firefox. I tried everything to force opening a new tab but thunderbird insists in creating a new firefox process, with is stoped with the message "Firefox is already open... blablabla"
(Reporter)

Comment 4

7 months ago
I have about  20 filters rules. Some of them take filtered messages to Trash

Comment 5

5 months ago
Multiple partitions does not necessaarily have an effect on performance. But folders on a non-local disk may affeect performance.

Even on a fast system it may normally take 2-5 seconds, depending on the server, to "unjunk" a message. (including mine)

Let's narrow what we are talking about:
Q1 - How many messages in Inbox?
Q2 - How many messages in Trash?
Q2 - How many messages in Spam folder? 
Are any folders on non-local disk?
Severity: normal → minor
Keywords: perf
Summary: Too slow doing automatic message movings (ex. marking as not spam) → Too slow (10-15 seconds) marking as not spam (not junk) and deleting messages
Whiteboard: [closeme 2017-07-01]
(Reporter)

Comment 6

5 months ago
A1- 342
A2- 0
A2- 0
All my messages are in a different partition, same disk. Maybe this clue makes differece: My linux system is on ext3, and the Mail folders partition is NTFS
Flags: needinfo?(dosergio)
(Reporter)

Comment 7

4 months ago
I gave up keeping my messages in a different disk. My previous intention was to share my thunderbird messages across Linux and Windows and it worked, despite de slowness. Once I passed the messages to the Linux home disk, all got fast again. I opened the bug because a symbolic link should mimic a local filesystem, but we saw that it creates a huge delay.
My doubt is if the blamed is the o.s, thunderbird or a both together when the mail folders are in a different disk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.