Intermittent test_element_state.py TestGetElementAttribute.test_boolean_attributes | IOError: Process killed because the connection to Marionette server is lost. Check gecko.log for errors (Reason: Connection timed out after 65.0s)

RESOLVED WORKSFORME

Status

defect
P3
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: aryx, Unassigned)

Tracking

({intermittent-failure})

Version 3
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

+++ This bug was initially created as a clone of Bug #1334142 +++

https://treeherder.mozilla.org/logviewer.html#?job_id=84730484&repo=autoland

[task 2017-03-17T21:44:40.718399Z] 21:44:40     INFO -  TEST-START | test_element_state.py TestGetElementAttribute.test_boolean_attributes
[task 2017-03-17T21:44:45.771984Z] 21:44:45     INFO -  testing boolean attribute <textarea autofocus>
[task 2017-03-17T21:44:55.521483Z] 21:44:55     INFO -  testing boolean attribute <textarea disabled>
[task 2017-03-17T21:45:10.644968Z] 21:45:10     INFO -  testing boolean attribute <textarea readonly>
[task 2017-03-17T21:45:24.557635Z] 21:45:24     INFO -  testing boolean attribute <textarea required>
[task 2017-03-17T21:45:32.119945Z] 21:45:32     INFO -  testing boolean attribute <object typemustmatch>
[task 2017-03-17T21:45:40.150917Z] 21:45:40     INFO -  testing boolean attribute <fieldset disabled>
[task 2017-03-17T21:45:48.261646Z] 21:45:48     INFO -  testing boolean attribute <iframe allowfullscreen>
[task 2017-03-17T21:46:25.901071Z] 21:46:25     INFO -  testing boolean attribute <form novalidate>
[task 2017-03-17T21:46:36.303856Z] 21:46:36     INFO -  testing boolean attribute <script async>
[task 2017-03-17T21:46:44.788551Z] 21:46:44     INFO -  testing boolean attribute <script defer>
[task 2017-03-17T21:46:49.523527Z] 21:46:49     INFO -  testing boolean attribute <track default>
[task 2017-03-17T21:46:54.470265Z] 21:46:54     INFO -  testing boolean attribute <button autofocus>
[task 2017-03-17T21:47:02.869219Z] 21:47:02     INFO -  testing boolean attribute <button disabled>
[task 2017-03-17T21:47:07.658023Z] 21:47:07     INFO -  testing boolean attribute <button formnovalidate>
[task 2017-03-17T21:47:11.155762Z] 21:47:11     INFO -  testing boolean attribute <img ismap>
[task 2017-03-17T21:47:16.299219Z] 21:47:16     INFO -  testing boolean attribute <optgroup disabled>
[task 2017-03-17T21:47:20.873388Z] 21:47:20     INFO -  testing boolean attribute <ol reversed>
[task 2017-03-17T21:47:24.752082Z] 21:47:24     INFO -  testing boolean attribute <video autoplay>
[task 2017-03-17T21:47:30.469576Z] 21:47:30     INFO -  testing boolean attribute <video controls>
[task 2017-03-17T21:47:38.116177Z] 21:47:38     INFO -  testing boolean attribute <video loop>
[task 2017-03-17T21:47:46.695884Z] 21:47:46     INFO -  testing boolean attribute <video muted>
[task 2017-03-17T21:47:51.253739Z] 21:47:51     INFO -  testing boolean attribute <details open>
[task 2017-03-17T21:47:55.410270Z] 21:47:55     INFO -  testing boolean attribute <dialog open>
[task 2017-03-17T21:48:00.405549Z] 21:48:00     INFO -  testing boolean attribute <menuitem checked>
[task 2017-03-17T21:48:04.718087Z] 21:48:04     INFO -  testing boolean attribute <menuitem default>
[task 2017-03-17T21:48:08.932544Z] 21:48:08     INFO -  testing boolean attribute <menuitem disabled>
[task 2017-03-17T21:48:12.677269Z] 21:48:12     INFO -  testing boolean attribute <input autofocus>
[task 2017-03-17T21:48:18.066723Z] 21:48:18     INFO -  testing boolean attribute <input checked>
[task 2017-03-17T21:48:22.852081Z] 21:48:22     INFO -  testing boolean attribute <input disabled>
[task 2017-03-17T21:48:27.712553Z] 21:48:27     INFO -  testing boolean attribute <input formnovalidate>
[task 2017-03-17T21:48:33.466494Z] 21:48:33     INFO -  testing boolean attribute <input multiple>
[task 2017-03-17T21:48:38.262694Z] 21:48:38     INFO -  testing boolean attribute <input readonly>
[task 2017-03-17T21:48:42.499369Z] 21:48:42     INFO -  testing boolean attribute <input required>
[task 2017-03-17T21:48:46.646177Z] 21:48:46     INFO -  testing boolean attribute <audio autoplay>
[task 2017-03-17T21:48:50.850264Z] 21:48:50     INFO -  testing boolean attribute <audio controls>
[task 2017-03-17T21:48:56.699332Z] 21:48:56     INFO -  testing boolean attribute <audio loop>
[task 2017-03-17T21:49:01.260255Z] 21:49:01     INFO -  testing boolean attribute <audio muted>
[task 2017-03-17T21:49:05.616614Z] 21:49:05     INFO -  testing boolean attribute <select autofocus>
[task 2017-03-17T21:49:11.833307Z] 21:49:11     INFO -  testing boolean attribute <select disabled>
[task 2017-03-17T21:55:41.972451Z] 21:55:41 CRITICAL -  mozdevice Timeout exceeded for _runCmd call '/home/worker/workspace/build/android-sdk18/platform-tools/adb -s emulator-5554 shell ps'
[task 2017-03-17T21:56:12.005396Z] 21:56:12 CRITICAL -  mozdevice Timeout exceeded for _runCmd call '/home/worker/workspace/build/android-sdk18/platform-tools/adb -s emulator-5554 shell ps'
[task 2017-03-17T21:56:42.051982Z] 21:56:42 CRITICAL -  mozdevice Timeout exceeded for _runCmd call '/home/worker/workspace/build/android-sdk18/platform-tools/adb -s emulator-5554 shell ps'
[task 2017-03-17T21:57:12.117761Z] 21:57:12     INFO -  mozdevice Timeout exceeded for _checkCmd call '/home/worker/workspace/build/android-sdk18/platform-tools/adb -s emulator-5554 shell echo'
[task 2017-03-17T21:57:12.171358Z] 21:57:12  WARNING -  TEST-UNEXPECTED-ERROR | test_element_state.py TestGetElementAttribute.test_boolean_attributes | IOError: Process killed because the connection to Marionette server is lost. Check gecko.log for errors (Reason: Connection timed out after 360.0s)
[task 2017-03-17T21:57:12.172184Z] 21:57:12     INFO -  Traceback (most recent call last):
[task 2017-03-17T21:57:12.172305Z] 21:57:12     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_harness/marionette_test/testcases.py", line 166, in run
[task 2017-03-17T21:57:12.172856Z] 21:57:12     INFO -      testMethod()
[task 2017-03-17T21:57:12.173927Z] 21:57:12     INFO -    File "/home/worker/workspace/build/tests/marionette/tests/testing/marionette/harness/marionette_harness/tests/unit/test_element_state.py", line 93, in test_boolean_attributes
[task 2017-03-17T21:57:12.174376Z] 21:57:12     INFO -      self.marionette.navigate(doc)
[task 2017-03-17T21:57:12.175256Z] 21:57:12     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 1657, in navigate
[task 2017-03-17T21:57:12.175903Z] 21:57:12     INFO -      self._send_message("get", {"url": url})
[task 2017-03-17T21:57:12.176604Z] 21:57:12     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/decorators.py", line 28, in _
[task 2017-03-17T21:57:12.177245Z] 21:57:12     INFO -      m._handle_socket_failure()
[task 2017-03-17T21:57:12.177844Z] 21:57:12     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/decorators.py", line 23, in _
[task 2017-03-17T21:57:12.178741Z] 21:57:12     INFO -      return func(*args, **kwargs)
[task 2017-03-17T21:57:12.179511Z] 21:57:12     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 721, in _send_message
[task 2017-03-17T21:57:12.180107Z] 21:57:12     INFO -      msg = self.client.request(name, params)
[task 2017-03-17T21:57:12.180663Z] 21:57:12     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/transport.py", line 284, in request
[task 2017-03-17T21:57:12.180860Z] 21:57:12     INFO -      return self.receive()
[task 2017-03-17T21:57:12.181382Z] 21:57:12     INFO -    File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/transport.py", line 211, in receive
[task 2017-03-17T21:57:12.181822Z] 21:57:12     INFO -      raise socket.timeout("Connection timed out after {}s".format(self.socket_timeout))
[task 2017-03-17T21:57:12.182414Z] 21:57:12     INFO -  TEST-INFO took 751453ms
This seems to be all about timeout issues with adb and the emulator?

> [task 2017-03-17T21:55:41.972451Z] 21:55:41 CRITICAL -  mozdevice Timeout exceeded for _runCmd call '/home/worker/workspace/build/android-sdk18/platform-tools/adb -s emulator-5554 shell ps'

Dupe of bug 1341466?
Flags: needinfo?(gbrown)
(In reply to Henrik Skupin (:whimboo) from comment #1)
> Dupe of bug 1341466?

Yes, I think so.
Flags: needinfo?(gbrown)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1341466
Lets keep it open for tracking purposes in Treeherder.
Status: RESOLVED → REOPENED
Depends on: 1341466
Resolution: DUPLICATE → ---
Priority: -- → P3
This failure shouldn't come up anymore given the patch on bug 1341466 landed.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.