Unable to set focus on html:input contained in tab widget

VERIFIED INVALID

Status

()

Core
XUL
P3
normal
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: hangas, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
Future
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
If focus() is called on an html:input inside of a tab widget ketstrokes do not
get processed by the html:input.  An example of this is the New Card dialog of
the address book.  Focus has been called on the first name html:input, but when
characters are typed in nothing happens.
(Reporter)

Updated

18 years ago
Blocks: 11494

Updated

18 years ago
Assignee: trudelle → evaughan

Comment 1

18 years ago
reassigning to evaughan to check for possible box involvement, and pass off to
kmcclusk if appropriate

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Updated

18 years ago
Blocks: 6710

Comment 2

18 years ago
mass-moving most m11 bugs to m12

Comment 3

18 years ago
Mass-moving non-PDT+ bugs to M13

Updated

18 years ago
Target Milestone: M13 → M14

Updated

18 years ago
Target Milestone: M14 → M15

Comment 4

18 years ago
*** Bug 6710 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
targeting
Target Milestone: M15 → M16

Updated

18 years ago
Target Milestone: M16 → M17

Comment 6

18 years ago
Mass moving M17 bugs to M18
Target Milestone: M17 → M18

Comment 7

18 years ago
mass-moving all bugs to m21 that are not dofood+, or nsbeta2+
Target Milestone: M18 → M21

Comment 8

18 years ago
(per trudelle). mass-moving all evaughan non-nsbeta3+ bugs to 'Future'
milestone
Target Milestone: M21 → Future

Comment 9

17 years ago
Tab was rewritten by ben. And this looks like a focus issue not a box issue.
Assignee: evaughan → ben
Status: ASSIGNED → NEW
This bug is old. XUL now has its own <textfield> widget, which handles focus
"correctly," afaik.

Not sure if this still exists, but closing as INVALID anyway.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 11

17 years ago
marking VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.