Closed Bug 6710 Opened 21 years ago Closed 20 years ago

[DOGFOOD][UI] First input control in dialogs should get focus

Categories

(Core Graveyard :: Profile: BackEnd, defect, P3)

All
Other
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 13490

People

(Reporter: bmartin, Assigned: racham)

References

Details

(Whiteboard: [PDT-])

latest Profile Manager/Creator (delivered 5/17/99)

1. Launch Apprunner on clean machine (delete Users50\, delete
windows\mozregistry.dat prior to running apprunner.exe)
2. Select Next on first screen
3. proceed through each screen and enter requested data.

Results:

User is required to click in the text field to make it active and/or in-focus.

Expected:

The cursor should be in-focus on the first element of UI on each screen of the
Profile Creator and the Profile Manager.
OS: Windows NT → other
Hardware: PC → All
*** Bug 6806 has been marked as a duplicate of this bug. ***
marking bug 6806 (mac and unix) duplicate of this bug,
changing platform to all
Status: NEW → ASSIGNED
Target Milestone: M9
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Moving the target fix version to M10.
Moving the target fix version to M10.
Gayatri,
Should this be marked fixed?  Last update was to move to M10.

Grace
Status: RESOLVED → REOPENED
Target Milestone: M9 → M10
Ooops! That was a mistake. Reopening the bug and moving it to M10.
Resolution: FIXED → ---
Clearing FIXED resolution due to Reopen.
P3s aren't going to make it in M10.  Bulk moving to M11.
Blocks: 12696
Target Milestone: M11 → M14
I think we could safely ship a beta1 without this.
No longer blocks: 12696
I'd be embarassed to ship this in a beta, but if it can't be done, it can't be
done. This is basic expected functionality for a well-formed Windows app. This
is also a subset of a large issue where focus is never set to the first field in
a form on a Web page, &c.
Chris, sounds like there's another bug this can be dup'd against then.  Do you
know the number off-hand?
I just performed a search on Bugzilla and I can't find any kind of metabug for
this behavior. I'm guessing it's just one of those really big ones that no one
ever filed thinking someone else would eventually... or else the words 'focus',
'input', and/or 'form' do not appear in the bug's summary. I'm going to file
that metabug now and see if anyone recognizes it as a duplicate.
D'oh! My bad. Focus should not be set in the first field on a Web page, etc.
What I meant to say was this: Dialogs should always have the focus set to the
first field in them when they are created. Other bugs exist in Bugzilla which
are to do with similar problems: 10160, 10161, 11494, and possibly others. I
remember filing bugs in this area last summer.
Target Milestone: M14 → M12
Marking the target fix version to M12.
Assignee: gayatrib → racham
Status: REOPENED → NEW
Depends on: 13490
This bug is dependent on 13490 getting fixed. Updating the bug to reflect the
dependency. Assigning to myself.
Status: NEW → ASSIGNED
Summary: Cursor should be In-Focus on first text field/option for all screens. → [DOGFOOD] First input control in dialogs should get focus
Whiteboard: [PDT-]
Putting on [PDT-] radar. Please send bug to pdt@netscape.com if you do not
agree.
Target Milestone: M12 → M13
It is a dependednt bug.
Moving the bug to M13.
Will followup on 13490 and update the bug status accordingly.
Summary: [DOGFOOD] First input control in dialogs should get focus → [DOGFOOD][UI] First input control in dialogs should get focus
Adding UI tag to the summary line. Makes isolation of UI bugs easier.
Target Milestone: M13 → M14
bug 13490 is set to be fixed in M14.
Changing the TFV of this bug to M14.
Component: Profile Manager → Profile Manager BackEnd
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → DUPLICATE
Marking this bug a dup of 13490. First text field should get default focus.

*** This bug has been marked as a duplicate of 13490 ***
.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.