disxons.co.uk - alert window pops up when trying to navigate on the menus

VERIFIED DUPLICATE of bug 88596

Status

Tech Evangelism Graveyard
English Other
VERIFIED DUPLICATE of bug 88596
16 years ago
3 years ago

People

(Reporter: Satheesh, Assigned: Tristan Nitot)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020401
BuildID:    2002040108

In the dixons site http://www.dixons.co.uk when I try to navigate on the menus
an alert window pops up.
I can navigate using the keyboard. It seems to work fine.
I did disable the javascript error/warnings bit in the Edit->Preferences->Debug
window. I still get the same error.




Reproducible: Always
Steps to Reproduce:
1.goto http://www.dixons.co.uk
2.Move the mouse over the menus on the left hand side of the screen.
3.Try disabling the errors and warnings in the
Edit->Preferences->debug->Javascript. The alert window still pops up.


Actual Results:  The alert window pops up and its not possible to use the mouse
on this menu

Expected Results:  I would expect that all such Javascript errors are disabled.
Atleast when I disable all errors/warnings in the
Edit->Preferences->debug->javascript window.


If its a problem in the way I am doing something would appreciate some more
information.
The alert is popped up by the page itself; not much we can do about that...

The page is using a menu system that is deisgned to work with the proprietary
DOMs of IE and NS4 and does not support the W3C standard DOM.

Over to evangelism.
Assignee: rogerl → momoi
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → English: Non-US
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: pschwartau → jeesun
Summary: alert window pops up when trying to navigate on the menus → alert window pops up when trying to navigate on the menus
Version: other → unspecified

Comment 2

16 years ago
Specifically, the popup is coming from this function in
view-source:http://www.dixons.co.uk/store_doc/js/heirmenu.js:


function Menu_displayMenu(level, name, e) {

               etc. 

    if(level > this.layer.length-1) {
        alert(level+ " exceeds the number of menu layers")
        return false;
    }

               etc. 

}

Comment 3

16 years ago
Altering to correct component
Assignee: momoi → nitot
Component: English: Non-US → Europe: West
QA Contact: jeesun → brantgurganus2001
Summary: alert window pops up when trying to navigate on the menus → disxons.co.uk - alert window pops up when trying to navigate on the menus

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 88596 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
v.
Status: RESOLVED → VERIFIED

Comment 6

15 years ago
tech evang june 2003 reorg
Component: Europe: West → English Other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.