Crash in java.lang.IllegalStateException: stateLabelString and stateString must not be null, but: (stateLabelString == null) = true and (stateString == null) = true at org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.getState(AndroidFxAccount.java)

RESOLVED DUPLICATE of bug 1508600

Status

()

defect
P5
critical
RESOLVED DUPLICATE of bug 1508600
2 years ago
7 months ago

People

(Reporter: sflorean, Unassigned)

Tracking

({crash})

55 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec+, firefox54 wontfix, firefox55 wontfix, firefox56 wontfix, firefox60 wontfix, firefox61 wontfix, firefox64 wontfix, firefox65 fix-optional, firefox66 fix-optional)

Details

This bug was filed from the Socorro interface and is 
report bp-bc79eaa4-7089-469b-bd04-9a8ff2170321.
=============================================================

The steps to reproduce this crash isn't 100% clear but found this after I disconnected my account from Settings -> Sign In (user is logged in) -> Disconnect. 
Then close the tabs and go to History panel -> Synced devices -> Get Started -> Have an account -> Sign In.

Reproducible 3/4 times.
I'm able to reproduce this crash in Nightly 56.0a1 (2017-06-21), by simply disconnecting from sync.
Not 100% reproducible but it happened 2/3 times.
tracking-fennec: --- → ?
[triage@July 5th] seems >50% repro rate though not a usual scenario (logged in, then disconnect, then log in again), may worth look into it.
Priority: -- → P2
change tracking flag since Wesly updated its importance
tracking-fennec: ? → +
This feels like some kind of a race to either clean or fill the account bundle. Something's going wrong around the edges there.
There are crash reports for this from 50 to 57, but 88% of all crashes are in 55, so this might be a side-effect of some 55 change.
See Also: → 1399904
See Also: → 1407316
I'm hoping to see the crash volume subside a bit now that Bug 1401318 landed.
See Also: → 1401318
The issue still happened on Nightly 61.0a1 (2018-04-15) but have received a different crash signature report 10c34ce8-2618-459c-81ea-f9a110180416 (https://crash-stats.mozilla.com/report/index/10c34ce8-2618-459c-81ea-f9a110180416).

The steps where the same by disconnecting from the FxAccount. The crash only happened once and was not able to reproduce it.
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: P2 → P5
See Also: → 1505720
Hi,

I was able to reproduce the issue (4/4) following this STR:
 1. Go to Settings -> Sign in, and sign in with valid credentials.
 2. Go to Settings -> Disconnect from your FxAccount
 3. Nightly crashes
Hardware: Unspecified → ARM
Status: NEW → RESOLVED
Crash Signature: [@ java.lang.IllegalStateException: stateLabelString and stateString must not be null, but: (stateLabelString == null) = true and (stateString == null) = true at org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.getState(AndroidFxAccount.java)]
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1508600
You need to log in before you can comment on or make changes to this bug.