Closed Bug 13492 Opened 20 years ago Closed 20 years ago

Menu accesskey (shortcut key) info should be in DTD.

Categories

(Core :: Editor, defect, P3)

defect

Tracking

()

CLOSED FIXED

People

(Reporter: rchen, Assigned: cmanske)

References

Details

Menu accesskey (shortcut key) info should be moved to DTD from XUL for
localization. Each accesskey ID should be related to its menu label. The entity
for accesskey should be next to the menu label entity.  Localization may change
the accesskey.
*** Bug 13493 has been marked as a duplicate of this bug. ***
Blocks: 12394
Don't know why it created two reports. Let's use 13492.  Thanks.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I checked in a fix.
QA Contact: ckritzer → rchen
Reassign QA to myself.
Status: RESOLVED → REOPENED
Component: XUL → Editor
Verified with browser. But I reopen this bug for editor component.
Assignee: davidm → cmanske
Status: REOPENED → NEW
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen.
OS: Windows NT → All
Hardware: PC → All
In particular, in EditorAppShell.xul, I see the task menu and help menu
accesskeys are hard-coded.  rchen--any others I'm not seeing?

Charley--feel free to reassign to me if you have too much on your plate.
Can you put the accesskey entity next to (next line) the menu label entity? like
navigator.dtd does?

When  the translation vendors do localization, they need to know which key
related to which menu and translate it according. For examples, "File" with
access key "F" could be translated like "XXXX(F)" in Japanese menu label.
Status: NEW → ASSIGNED
Target Milestone: M12
Thanks for clarifying what the "problem" really was - I was just trying to
ask what was the problem and got a collision in bugsplat!
We have more pressing priorities for M11 than this. I will do it during M12.
Charlie, how long does it take to do this? The reason for asking is that we are
sending out files for translation early next week and we would like to get as
many fixes as we can. Thanks!
I'll do this this weekend if know one else is.
Charles, let me do it over the weekend and sent it to you on Monday for
verification and checkin. How does it sound to you?
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
I have moved menu accesskey (shortcut key) info to DTD from XUL and gave the
files to Charles verified.
Blocks: 16654
Everything looks fine to me -- closing bug.
Status: VERIFIED → CLOSED
You need to log in before you can comment on or make changes to this bug.