Commands in listener.js miss checks for valid top-level browsing context - no NoSuchWindow failure thrown

RESOLVED DUPLICATE of bug 1368492

Status

enhancement
P2
normal
RESOLVED DUPLICATE of bug 1368492
2 years ago
a year ago

People

(Reporter: whimboo, Unassigned)

Tracking

(Blocks 2 bugs)

Version 3
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [spec][17/03])

Similar to bug 1322383 but for the listener.js framescript.

Right now we do not always check for a valid top-level browsing context. Which means in case of navigating away from a frame, which might close it, following commands can fail because the context is no longer available.

In those cases each of the methods should throw a NoSuchWindowException.
Priority: P2 → P1
Blocks: 1255946
Priority: P1 → P2
I don’t understand the description of this bug.  Before a command
request reaches the frame script, chrome space checks that the
browsing context is still open.  This returns a no such window
error.  Is that not sufficient?
Flags: needinfo?(hskupin)
I think that bug 1368492 actually should have implemented that from the chrome site.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(hskupin)
Resolution: --- → DUPLICATE
Duplicate of bug: 1368492
You need to log in before you can comment on or make changes to this bug.